Filtre automatique et somme

[Résolu/Fermé]
Signaler
-
 Poucoule -
Bonjour,
Sur un tableur Excel comprenant 3 tableaux avec des noms d'objets et des calculs associés, j'aimerais pouvoir faire la somme d'un même objet dans un tableau de synthèse afin d'éviter de tout réécrire à chaque fois.
Pour cela j'utilise des listes déroulantes mais je me demandais s'il était possible de créer un filtre automatique pour que lors du choix de l'objet, la somme de cet objet dans les tableaux du dessus se retrouve dans le tableau de synthèse.
Merci d'avance pour votre aide

2 réponses

Messages postés
13117
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
19 octobre 2021
2 264
Bonjour,

Si tu utilises un filtre sur un tableau ce n'est plus la fonction SOMME qu'il faut utiliser au dessous du tableau mais la fonction SOUS.TOTAL qui ne fera la somme que des lignes restant visibles après le filtre

Cdlmnt
Via
Messages postés
26232
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2021
6 087
Bonjour (salut Via)
Pour info à toutes fins utiles,pour que la somme ne se fasse que sur les lignes visibles, il faut placer le code (9; ou (109; dans la fonction sous total
=SOUS.TOTAL(9;champ complet à sommer)une formule en ligne avec le menu déroulant:

sinon; il est possible d'utiliser
=SOMME.SI(Cell nom d'objet;list des objets;champ à sommer)

Bien cordialement
Bonjour,
Merci pour vos réponses, j'ai déjà exploré cette solution mais j'ai l'impression que cela ne résous pas mon problème ou du moins pas complétement, pour y voir plus claire voici mon tableau :

RDC --------------------------------------- Péclairage (W)
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
SdB ------------------------------------------- 200
Choisir dans la liste
Choisir dans la liste
TOTAL

R+1 ----------------------------------------Péclairage (W)
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
Sdb --------------------------------------------150
Choisir dans la liste
Choisir dans la liste
TOTAL

R+2 ---------------------------------------Péclairage (W)
Choisir dans la liste
Sdb ---------------------------------------------100
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
TOTAL

Synthèse bâtiment
Type de pièces -----------------------------Péclairage (W)
Choisir dans la liste
Choisir dans la liste
Sdb ---------------------------------------------------------- 450
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
Choisir dans la liste
TOTAL

En gros, il faudrait qu'il y est un calcul automatique (somme) de la puissance d'éclairage pour chaque type de pièce sachant que leur emplacement n'est pas défini préalablement (via les listes déroulantes). J'espère que cela éclaircira le problème.
Merci d'avance pour votre aide
Messages postés
26232
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2021
6 087
A propos d'éclairage, c'est plutôt votre fichier qu'il nous faudrait, parce que là, on a du mal à voir comment sont organisées vos données et ce que vous voulez obtenir
Sivous pouvez déposer un modèle sur:
https://www.cjoint.com/
et revenir ici coller le lien donné par le site
crdlmnt
Voilà le fichier :
http://cjoint.com/?0DojPedPhWa
Merci
Cdt
Messages postés
26232
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2021
6 087
Bonjour

en B32,

=SOMME.SI($A$4:$A$28;$A32;$B$4:$B$28)
attention aux positions du signe $
tirer la même formule en C32
tirez ensuite l'ensemble des deux jusqu'en 43
en B et C 44 faite une somme simple

crdlmnt
Merci beaucoup pour ton aide ! ça fonctionne très bien !