Importer informations après choix dans une liste deroulante

Résolu/Fermé
Signaler
Messages postés
20
Date d'inscription
mercredi 1 avril 2015
Statut
Membre
Dernière intervention
21 août 2015
-
Messages postés
20
Date d'inscription
mercredi 1 avril 2015
Statut
Membre
Dernière intervention
21 août 2015
-
Bonjour,

J'ai besoin de votre aide pour une action que je n'arrive pas à réaliser sur Excel 2010.

Ce que j'aimerai faire serait de permettre à l'utilisateur de choisir via une liste déroulante une entreprise (texte) ce qui remplit directement une cellule, que l'on aura choisi avant, de ses informations.

A coté de cette feuille excel, j'en ai une deuxième qui sert de "base de donnée" où les entreprises sont listées ainsi que leurs informations.

Exemple :
Entreprises Adresses Tel
E1 Lyon 092208...


Savez vous si c'est possible ? et comment pouvons nous y arriver ?

Merci d'avance pour votre aide

2 réponses

Messages postés
3365
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2021
485
Bonjour howiz, et bienvenue,

Quand on joint un fichier-test, ou le fichier, c'est plus commode pour les intervenants.

1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
20
Date d'inscription
mercredi 1 avril 2015
Statut
Membre
Dernière intervention
21 août 2015

J'ai réussi en suivant le commentaire de via55. Merci, je ferais ça la prochaine fois !
Messages postés
13203
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 décembre 2021
2 289
Bonjour howiz

Bien sûr c'est possible :

1) la base de données qui comporte plusieurs colonnes doit impérativement avoir dans sa 1ere colonne l'objet de la recherche (dans ton cas les noms des entreprises)
2) selectionner la plage entière des lignes et colonnes de la base (triée) et la nommer Base (clic droit Nommer plage)
3)Selectionner seulement la 1ere colonne et la nomme Entreprises
4) La liste déroulante dans l'autre onglet est obtenue avec Données Validation de données, Autoriser Liste et dans Source mettre = Entreprises
5) En supposant cette liste déroulante en cellule B2, pour avoir dans une autre cellule l'info dans la 2eme colonne de la Base correspondante à l'entreprise sélectionnée mettre la formule :
=RECHERCHEV(B2;Base;2;0)
(le 0 demande une correspondance exacte)
Pour avoir l'info de la 3eme colonne la formule dans une autre cellule sera =RECHERCHEV(B2;Base;3;0)
etc

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
20
Date d'inscription
mercredi 1 avril 2015
Statut
Membre
Dernière intervention
21 août 2015

J'avais vu ça sur internet mais bizzarement, j'ai reussi cette fois-ci ! merci