Macro à problème...

Résolu/Fermé
ButteDuLac
Messages postés
492
Date d'inscription
jeudi 5 mars 2009
Statut
Membre
Dernière intervention
24 octobre 2020
- 26 mars 2015 à 19:23
ButteDuLac
Messages postés
492
Date d'inscription
jeudi 5 mars 2009
Statut
Membre
Dernière intervention
24 octobre 2020
- 26 mars 2015 à 19:50
Bonjour,
J'ai enregistré une macro qui devait servir à masquer deux colonnes (E et F), puis placer mon curseur dans la cellule A4 (en fait, j'ai fait HOME et mon Tableau débute à A4, alors c'est allé automatiquement.)

Voici le texte que j'obtiens en VBA :
Columns("E:F").Select
Range("E2").Activate
Selection.EntireColumn.Hidden = True
Range("A4").Select

Résultat : toutes les colonnes de A à J se masquent!

Pourtant, j'avais créé ma macro (CommandButton) pour afficher les colonnes E:F et je n'ai pas eu de problème!!??!!??

(En fait, honnêtement, je n'ai aucune idée ce que les deux lignes commençant par Range signifient ni pourquoi elles sont là, ni si c'est ça le problème... j'ai essayé de les supprimer, ça fait exactement le même résultat...)

Quelqu'un peut m'aider, svp?

1 réponse

Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
534
26 mars 2015 à 19:45
Bonjour,

Vérifie si tu n'as pas des cellules fusionnées sur la plage A:J.

A+
0
ButteDuLac
Messages postés
492
Date d'inscription
jeudi 5 mars 2009
Statut
Membre
Dernière intervention
24 octobre 2020
38
26 mars 2015 à 19:50
Ah! Ben oui!
Je l'ai « défusionnée »...
Et maintenant... devinez quoi? Tout fonctionne!!!!
Merci!
:D
0