Pluieurs caratères à chercher dans 1 cellule

[Résolu/Fermé]
Signaler
-
 Pascale -
Bonjour,

Ma cellule A1, A2 et A3 contient:
Maître d'équipage - SC-DED-05
2e mécanicien - SO-MAO-03
Maître d'équipage - SC-DEL-06

Sans séparer les caractères je cherche une formule qui m'indiquerait si SC-DED-05 OU SC-DEL-06 est présent dans la cellule. J'essaie d'utiliser:
SI(ESTNUM(CHERCHE("SC-DED-05";A1);CHERCHE("SC-DEL-06";A1));"Oui";"Non") et ça ne fonctionne pas, j'ai trop d'argument. Avez vous une idée, quelle formule serait plus efficace?

4 réponses

Messages postés
17515
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 septembre 2021
4 712
Bonsoir,

Pour tester la cellule A1, tu peux faire

=SI(NB.SI(A1;"SC-DED-05")+NB.SI(A1;"SC-DEL-06")>0;"présent";"absent")

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Merci Mike-31
Messages postés
54581
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
8 septembre 2021
16 514
Tu nous faciliteras la compréhension du problème et la rédaction de sa solution, en nous envoyant ton fichier Excel.
Va dans https://www.cjoint.com/ pour créer le lien, et reviens le coller ici.

Mais déjà, la fonction SI demande 3 arguments ; tu en as mis 4 !
Merci quand même Raymond, ccm81 a répondu à ma question.
Messages postés
10087
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
7 septembre 2021
2 197
Bonjour

essaies ceci
=SI(ESTNUM(CHERCHE("SC-DED-05";A1));"OUI";SI(ESTNUM(CHERCHE("SC-DEL-06";A1));"Oui";"Non"))

Cdlmnt
Super,ça fonctionne! Merci ccm81!!!
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
878
Salut le Forum

Essaye ceci :
=SI(OU(ESTNUM(CHERCHE("SC-DED-05";A1));ESTNUM(CHERCHE("SC-DEL-06";A1)));"Oui";"Non")

Mytå
Merci Myta