Recherche sur un tableau et suppression automatique de données

Résolu/Fermé
Signaler
Messages postés
4
Date d'inscription
vendredi 6 mars 2015
Statut
Membre
Dernière intervention
9 mars 2015
-
Messages postés
4
Date d'inscription
vendredi 6 mars 2015
Statut
Membre
Dernière intervention
9 mars 2015
-
Bonjour,

Je suis confronté à un problème sur excel, il me semble assez complexe et je vais essayer de l'exposer le plus clairement possible:

J'ai 4 colonnes et plus de 500 lignes (avec des données). J'ai deux colonnes "communes", l'une d'elle liste les communes d'un territoire X (que j'étudie) et l'autre est une liste exhaustive des communes d'une région. Je souhaite enfaite supprimer les communes hors de mon territoire et leurs infos (les infos étant contenue sur la même ligne que les communes, dans les deux autres colonnes de mon tableau).

Au final ça correspondrait à une recherche et comparaison dans et de deux colonnes, dont l'une serait la source et l'autre la cible (on souhaite conserver la colonne source intacte, la cible se verra amputée des villes/info qui n'apparaissent pas dans ma colonne source). Au final je devrais avoir autant de lignes que j'ai de communes dans ma colonne source.

J'ai bien demandé au seigneur de me venir en aide mais mes questions sont restées sans réponses, alors je m'en remet à vous...

Advienne que pourra, cordialement. VL



2 réponses

Messages postés
16197
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
21 janvier 2022
1 580
Bonjour,

vous utilisez un PC ou un Mac ????

vous aurez a faire la manip une ou plusieures fois ????
0
Messages postés
4
Date d'inscription
vendredi 6 mars 2015
Statut
Membre
Dernière intervention
9 mars 2015

Bonjour, je suis sur un mac (contre mon gré c'est pour mon boulot).
A priori ce serait juste une fois..

Si tu as une solution à proposer ce serait cool, je me sens pas de tout faire à la main et puis pourquoi faire simple quand on peut faire compliqué. A plus
0
Messages postés
13346
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 janvier 2022
2 325
Bonsoir

Une possibilité sans macro avec quelques manips simples:

En supposant tes données en colonnes A,B,C et D et commençant en A2 (si titres en ligne1)
1) en E2 mettre la formule : =SI(NB.SI($A:$A;$B2)>0;B2;"zzz")
2) Étirer la formule jusqu'en G2
3) Sélectionner la plage E2:G2 et faire étirer les formules au bas des 500 lignes (double-clic sur le petit carré noir en bas à droite de G2)
4) Sélectionner les 3 colonnes E,F,G et les coller en H par Collage spécial Valeurs uniquement (pour éliminer les formules
5) Sélectionner colonnes H,I et J et faire Trier par ordre alphabétique sur la colonne H
6) Il ne reste plus (après vérification que le nombre de communes en H correspond bien à celui en A) qu'à supprimer les colonnes B à G et les lignes en bas de tableau avec zzz

Cdlmnt


0
Messages postés
4
Date d'inscription
vendredi 6 mars 2015
Statut
Membre
Dernière intervention
9 mars 2015

Salut, merci beaucoup de ta réponse ça a marché pour moi, en espérant que ça puisse en aider d'autres, bonne journée à toi. Cordialement, VL
0