Problème excel avec la formule SI inférieur ou supérieur

Fermé
Signaler
Messages postés
2
Date d'inscription
mercredi 21 janvier 2015
Statut
Membre
Dernière intervention
21 janvier 2015
-
Messages postés
26314
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 décembre 2021
-
Bonsoir ,
j'ai besoin d'aide pour la formule "SI "car mes résultats finaux sont étranges , alors je pense avoir fait une erreur dans la formule.

Voici les explications :
1er Case avec un Prix ( ex : C83)
2eme Case avec un prix ( ex : F83)
3eme Case ,
Si Case 2 < Case 1 alors le cacul à faire est : 90+10x(Case n°1-Case n°2)/Case n°1 mais si Case 2 > Case n°1 le calcul à faire est : 90-90x (Case N°2 - Case n°1)/ Case n°1

J'ai trouvé cela pour la formule :
=SI(F83=F83<=$C$83;90+10*(($C$83-F83))/$C$83;SI(F83=F83>=$C$83;90-90*((F83-$C$83/$C$83))))

Cordialement
Merci d'avance
A voir également:

2 réponses

Messages postés
26314
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 décembre 2021
6 133
Bonsoir
pourquoi écrivez vous F83=F83...et surveillez les parenthèses qui se "baladent" un peu
la deuxième con diton n'est pas utile (si ce n'est pas le premier cas, c'est le second)
et ce n'est pas la peine non plus de placer <= dans le premier cas et >= dans le second, car dans le cas = Excel s'arrête au premier


=SI(F83<=$C$83;90+10*($C$83-F83)/$C$83;$C$83;90-90*(F83-$C$83)/$C$83)

crdlmnt
Messages postés
2
Date d'inscription
mercredi 21 janvier 2015
Statut
Membre
Dernière intervention
21 janvier 2015

Bonsoir Vaucluse , je vous remercie déjà pour votre réponse .
Je suis une méthode à suivre , je suis néophyte dans l'utilisation des différentes formules qui sortent de "'ordinaire" sous excel.

Mais, pour paraître idiote , dans votre formule , si le cas 1 ne se déroule pas alors , c'est le cas 2 qui s'applique nous sommes d'accord ?

De plus en essayant de copier votre formule , " vous avez un nombre trop important d'arguments pour cette fonction"


Je vous remercie d'avance.
Messages postés
26314
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 décembre 2021
6 133
Effectivement, il y a une petite erreur dans ma proposition que j'ai copié de la votre et j'ai oublié de retirer un C83 de trop


=SI(F83<=$C$83;90+10*($C$83-F83)/$C$83;90-90*(F83-$C$83)/$C$83)

note: cette formule renvoie #DIV/0 si C83 est vide ou égal à 0, mais je pense qu'il n'y a pas ce risque puisque C83 est une référence bloquée.

Par contre oui, vous avez bien compris, si la 1° condition ne s'applique pas, c'est la dernière qui est prise en compte

crdlmnt
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 981
Bonjour,

F83=F83<=$C$83 n'est pas un test valide.

F83<$C$83
ou
F83<=$C$83 oui
choisi bien sur quel test tu mets le = en plus, le premier rencontré sera celui exécuté.

eric