Connexion impossible via DNS de No-Ip / Port Forwarding [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014
-
Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014
-
Bonjour,
Voila le matériel que je possède :
- Routeur Linksys wrt54g
- Livebox 2 FR Sagemecom
- Raspberry pi modèle B, serveur Nginx installé
- PC portable classique avec navigateur Firefox

Et mon problème :
Je n'arrive pas à me connecter au site présent sur mon raspberry depuis l'extérieur avec le dns No-ip que j'ai configuré, alors que mon site est accessible depuis le local. Voici, en quelques images, comment j'ai paramétré le port forwarding et no-ip :

Schéma de mon réseau :



Port Forwarding sur la livebox, qui renvoie les requetes http et https vers le routeur Linksys :



Port Forwarding sur le routeur, qui renvoie donc les requetes http et https vers mon raspberry :



Ajout du DNS de No-IP sur la livebox :



Enfin, l'ajout du dns sur mon routeur (je ne sais pas si c'est vraiment utile :P) :



Je reprécise bien que le site web de mon raspberry est joignable en interne, mais pas par l'extérieur...

Quel est le problème ?
Merci

3 réponses

Messages postés
94572
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
21 octobre 2020
10 729
Salut,
voilà qui est clairement expose, on sent la maitrise :-)

Deux routeurs nat en cascade, ça fait au moins un de trop :-(
mais bon,
j'ai la même chose chez moi ;-)

Pourquoi ne mets tu pas ton ... "serveur" directement sur ta lbx ?
au fait, tu l'as testé comme ça ?
aussi,
est qu'il est joignable d'un PC directement sur la box ?
PS,
pas la peine de masquer ton adresse ip privée, c'est inutile, elle n'est pas joignable de l'extérieur.
enfin,
d'où testes tu de chez toi ou d'ailleurs ?
un routeur normalement constitué ne sait pas router sa propre adresse, il faut tester depuis l'extérieur ou via un vpn.


et ... Voili Voilou Voila !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014

Je vais vérifier, en attendant, je vais brancher le serveur sur la livebox et voir si j'arrive à faire fonctionner le dns
Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014

Bon, le serveur connecté à la livebox, en ayant configuré les NAT HTTP et HTTPS vers celui-ci, ça ne marche toujours pas (meme en local). J'en conclus qu'il sagit bien d'un filtre sur le serveur qui bloque... Je vais me pencher là dessus.
Je me souviens que ça marchait très bien au mois de septembre, avec le meme matos, et ça ne marche plus depuis que j'ai réinstallé mon serveur qui avait planté (j'ai dû mal configurer quelque part). Je m'occupe de ça et je tiendrai au courant :) En tout cas merci pour ton aide brupala :)
Messages postés
94572
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
21 octobre 2020
10 729
Bon courage,
mais tu avais changé l'adresse ip du serveur quand tu l'as connecté sur la bosque ?
Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014
>
Messages postés
94572
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
21 octobre 2020

Oui bien entendu, je l'avais passé de 192.168.200.13 à 192.168.1.98
Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014

Bon, je ne trouve toujours pas de solution au niveau du serveur... En revanche (avec la meme configuration qu'au début), lorsque depuis l'extérieur je met ***********.ddns.net, le navigateur me redirige vers 192.168.200.13, alors que je suis à l'extérieur (et bien évidemment, rien ne s'affiche)... Est-ce une piste ?
Messages postés
94572
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
21 octobre 2020
10 729
salut,
comment vois tu qur tu es redirigé à cette adresse ?

--
Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014

Salut,
Dans ma barre d'adresse (celle de mon téléphone connecté à internet via la 3G), "***********.ddns.net" devient "https://192.168.200.13"
Messages postés
3004
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
21 octobre 2020
386
Hello,

Je rentre vite fait dans la conversation.
Seulement la LiveBox doit enregistrer son adresse IP externe/publique auprès du service DDNS.
Le souci c'est que tu as paramétré aussi le routeur, qui lui ne dispose pas d'adresse IP publique. Il écrase surement ce que la Livebox fait.
Laisse uniquement la livebox faire le DDNS, supprime/désactive cela sur le routeur.
Pour voir si ça fonctionne, dans une invite de commande fais un :

nslookup monsupernom.ddns.net


Et regarde ensuite la réponse qui est donnée, si c'est ton IP publique c'est gagné.
Messages postés
9
Date d'inscription
mercredi 17 décembre 2014
Statut
Membre
Dernière intervention
26 décembre 2014

Bonjour à tous et merci pour votre aide,

Depuis quelques jours, le problème est réglé ! Le souci ne se trouvait non pas dans les paramétrages que j'ai exposé ci-dessus, mais dans la configuration de mon serveur NginX. En effet, j'ai simplement réinstallé tout le serveur avec les bons parametres et voila !
Merci à tous