Combinaison de fonction avec la fonction "Indirect"

Résolu/Fermé
Signaler
Messages postés
49
Date d'inscription
vendredi 17 janvier 2014
Statut
Membre
Dernière intervention
11 août 2015
-
Messages postés
49
Date d'inscription
vendredi 17 janvier 2014
Statut
Membre
Dernière intervention
11 août 2015
-
Bonjour,

Je possède un fichier Excel avec un onglet par année et un onglet récapitulatif par Région.

J'aimerais, dans le récapitulatif, que les données se remplissent automatiquement en fonction du nom de la personne.
Actuellement, j'arrive à remplir les données en changeant systématiquement les coordonnées des cellules concernées pour chaque personne.
Seulement, étant donné que mon fichier réel comporte environ 100 personnes, j'aurais aimé automatiser cela.

Voici le lien cjoint d'un extrait du fichier : https://www.cjoint.com/?0Lnp5uCYp5F

J'ai pensé à la fonction "Adresse" mais je n'arrive pas à la combiner avec la fonction "Indirect".

Merci de votre aide.

Cordialement,

Guillaume.

3 réponses

Messages postés
10185
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 novembre 2021
2 251
Bonjour

Je ne sais pas si j'ai bien compris la question
https://www.cjoint.com/?3Lns4K3WYPC
Cdlmnt
Messages postés
13198
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
27 novembre 2021
2 288
Bonsoir

Formule à mettre en B3 de Recap :
=NB.SI.ENS(INDIRECT("'"&$B$1&"'!$B$1:$J$1");1;INDIRECT("'"&$B$1&"'!$B$" &EQUIV($A3;INDIRECT("'"&$B$1&"'!$A:$A");0)&":$J$"& EQUIV($A3;INDIRECT("'"&$B$1&"'!$A:$a");0));">0")

Changer le 1 en 3 et 2 pour les cellules à droite suivantes , etc

Cdlmnt
Messages postés
49
Date d'inscription
vendredi 17 janvier 2014
Statut
Membre
Dernière intervention
11 août 2015

Bonjour,

Merci à vous deux pour ce rapide retour.

La solution de via55 correspond parfaitement à ce que je recherchais.

Merci encore !

Cordialement,

Guillaume.