Formules pour extraire des données TEXTE [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
lundi 8 décembre 2014
Statut
Membre
Dernière intervention
15 janvier 2015
-
Messages postés
12185
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2020
-
Bonjour,
Je dois analyser beaucoup de données "informatives" qui sont sous forme de texte. J'utilise régulièrement les filtres qui permettent d'identifier lettres et textes dans les cellules (filtre : Contient). Mais ne peut-on pas introduire une formule dans une cellule pour identifier ces textes? Ex:



Dans ce tableau, colonne A est renseignée automatiquement par des codes articles, colonne B étant le nom (désignation) de ces articles. J'insère les deux colonnes suivantes afin d'identifier des critères qui me sont importants (type, type 2) - dans cet exemple, les critères NEW, FD et TRI doivent être identifiés et reportés dans les cellules juxtaposées. Ici, je l'ai fait à la main, en filtrant ma colonne B par le champ "filtres textuels". Dans mes bases de données j'ai plus de 6000 lignes, je ne peux pas "filtrer" à la main. Existe-t-il une formule SI qui permet d'analyser des TEXTES et non des valeurs? Du style : Si cellule B2 contient NEW alors cellule C2 = NEW, sinon C2 reste vide.
Merci d'avance!!!

1 réponse

Messages postés
12185
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2020
2 484
Bonjour,

En C2, saisir la formule :

=SI(ESTERREUR(CHERCHE("NEW";B2));"";"NEW")
Messages postés
4
Date d'inscription
lundi 8 décembre 2014
Statut
Membre
Dernière intervention
15 janvier 2015

Fantastique Franck! Maintenant ça à l'air si simple!!!
Merci plein de fois!
Antonia
Messages postés
12185
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
21 septembre 2020
2 484 >
Messages postés
4
Date d'inscription
lundi 8 décembre 2014
Statut
Membre
Dernière intervention
15 janvier 2015

de rien!
A+