Transformer des heures en jours [Fermé]

Signaler
Messages postés
2
Date d'inscription
samedi 29 novembre 2014
Statut
Membre
Dernière intervention
30 novembre 2014
-
Messages postés
2
Date d'inscription
samedi 29 novembre 2014
Statut
Membre
Dernière intervention
30 novembre 2014
-
bonjour
je vous soumets mon souci tel que suit:

sous excel 2010

A1---> nb d'heures au format [hh]:mm:ss (heures effectuées)
B1---> 07:00 format idem (journée de travail)

C1---> =ARRONDI.INF(A1/B1;0)+A1-B1*ARRONDI.INF(A1/B1;0) au format j"j"hh:mm

Si:
A1= 220:00
B1= 7:00

C1= 31j 03:00 donc CORRECT (journées de travail de 7:00)

problème n° 1

A1=227:00
B1=7:00

C1= 1j03:00 au lieu de 32j03:00

donc comment obtenir des jours supérieur à 31 qui correspondent apparemment à un mois occulté par la formule ? Sachant que je dois rester en jours et ne pas faire apparaître des mois qui seraient ingérables (30j;31j;28j)

problème n° 2

pour travailler en heures négatives je prends comme référence calendaire 1904
pour pallier au décalage de 1 jour que j'ai constaté j'ai modifié la formule comme suit:

A1=220:00 au format [hh]"h"mm;[Rouge]"-"[hh]"h"mm;0
B1=7:00 au format [hh]:mm:ss
B2=24:00 au format [hh]:mm:ss (journée excel)

C1---> =ARRONDI.INF(A1/B1;0)+A1-B1*ARRONDI.INF(A1/B1;0)-B2 donc 31j03:00

A4=220:00 , A5=0:00 et A1=A4-A5=220h00
A4=220:00 , A5=440:00 et A1=A4-A5=-220h00

donc si A1>0 je dois ôter B2 à la formule
si A1<0 je dois ajouter B2 à la formule

Comment en C1 peut-on utiliser soit l'une soit l'autre suivant le signe de A1 ?

J'espère être assez clair
Je bataille sur cette formule depuis une semaine en vain

Merci par avance
A voir également:

4 réponses

Messages postés
25952
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 866
Bonjour
est ce que celle ci conviendrait:

=ENT(A1/B1)&"j "&TEXTE((A1-ENT(A1/B1)*B1);"hh")&" h"

crdlmnt
Messages postés
2459
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
1 avril 2021
957
Bonjour,
Si l'affichage des 00 min ne rebute pas
=ENT(A1/B1)&"j "&SUBSTITUE(SUBSTITUE(TEXTE((A1-ENT(A1/B1)*B1);"hh:mm:ss");":";" h ";1);":";" min ";1)&" s"
Messages postés
53596
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
15 638
problème n° 1.

J'avais trouvé une formule semblable
=ARRONDI(A1/B1;0)&"j "&ARRONDI(MOD(A1;B1)*24;0)&"h"
qui est valable pour les durées avec des heures rondes (pas de minutes).
Ainsi avec 227:00:00 en A1 on affichera 32j 3h.

Si les durées comportent des minutes, ce sera
=ARRONDI(A1/B1;0)&"j "&ARRONDI(MOD(A1;B1)*24;2)&"h"
Ainsi avec 227:15:00 en A1 on affichera 32j 3,25h.

babik doit noter que nos 3 formules donnent un résultat au format TEXTE, donc inutilisables pour d'autres calculs !

Cordialement.
Messages postés
53596
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
15 638
problème n° 2.

Il ne faut pas changer de calendrier.
Il ne faut pas enlever un jour.
Il faut deux colonnes différentes pour calculer les durées.

Tu déplaces B1 et B2 en colonne C
En A1 on met la formule =SI(A4>C4;A4-C4;0)
En B1 on met la formule =SI(A4<C4;0;A4-C4)
ainsi la colonne A permet de totaliser les heures en plus et la colonne B les heures en moins ; en dernière ligne il suffira de faire Total A - Total B
Messages postés
2
Date d'inscription
samedi 29 novembre 2014
Statut
Membre
Dernière intervention
30 novembre 2014

merci à vous
dès que je suis de repos je teste en live sur mon pointage du boulot
et je vous tiens au courant

à+