Pourcentage sur somme de valeurs qui changent tous les mois [Résolu/Fermé]

Signaler
Messages postés
72
Date d'inscription
jeudi 10 juillet 2014
Statut
Membre
Dernière intervention
17 juin 2019
-
Messages postés
25162
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 juillet 2020
-
Bonjour,

J'aimerai de l'aide sur une formule qui me permettrai de voir le pourcentage de satisfaction et insatisfaction tous les mois.

Je vous envoie ci-joint le lien pour que vous puissiez voir le fichier.

Je vous remercie d'avance

https://www.cjoint.com/?DKArntx0DjQ

3 réponses

Messages postés
25162
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 juillet 2020
5 347
Bonjour
une formule à placer en J2, qui s'adaptera aux titres de colonnes
attention, les valeurs avec 0 sont texte et doivent être encadrée par des guillemets, pas les autres
=SOMMEPROD((($B$1:$H$1=7)+($B$1:$H$1="07")+($B$1:$H$1=8)+($B$1:$H$1="08")+($B$1:$H$1=9)+($B$1:$H$1=9)+($B$1:$H$1=10))*(B2:H2))/I2

si toutefois votre titre de colonne sont toujours 7 07 8 08 ect, et que vous grouper toujours le x avec le 0x dans les calculs,vous pouvez simplifier comme suit:

=SOMMEPROD(((($B$1:$H$1)*1=7)+(($B$1:$H$1)*1=8)+(($B$1:$H$1)*1=9)+($B$1:$H$1=10))*(B2:H2))/I2

Bien sur le principe est le même pour K avec les titres de colonnes correspondants

attention aux signes et à toutes les parenthèses.

crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
72
Date d'inscription
jeudi 10 juillet 2014
Statut
Membre
Dernière intervention
17 juin 2019

Merci beaucoup!!!!!
Messages postés
25162
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
5 juillet 2020
5 347
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt