Filtre auto+nb.si sur plusieurs intitulés et plusieurs résultat [Résolu/Fermé]

Signaler
Messages postés
63
Date d'inscription
mardi 7 mai 2013
Statut
Membre
Dernière intervention
23 avril 2020
-
Messages postés
127
Date d'inscription
dimanche 2 novembre 2014
Statut
Membre
Dernière intervention
20 janvier 2015
-
Bonjour CCM,

Voici mon problème:

J'ai une colonne avec Filtre Auto J9:J60, contenant plusieurs intitulés, ex: Normal; Sans Sel;...

Sur une autre feuille je souhaite avoir pour chaque intitulé le nombre de fois où il apparaît dans la colonne précédemment évoquée lorsque le Filtre est actif. En gros quand je filtre sur l'intitulé Normal je devrais obtenir ceci:

[NORMAL ][ 8] (le 8 est un exemple vous l'aurez compris)
[SANS SEL][ 0]

Et si je filtre sur l'intitulé Sans sel, je devrai avoir ceci:

[NORMAL ][ 0]
[SANS SEL][ 3] (là encore 3 étant un exemple)



Jusqu'ici j'ai essayé avec SOUS.TOTAL puis avec NB.SI mais je n'obtiens pas ce que je souhaite.

Si par hasard vous aviez la solution je suis preneur!

Un grand merci à celles et ceux qui se pencheront sur mon problème!

5 réponses

Messages postés
127
Date d'inscription
dimanche 2 novembre 2014
Statut
Membre
Dernière intervention
20 janvier 2015
3
Bonjour SpcCwb,
La fonction NB.SI devrait fonctionner.
Envoie-nous un fichier exemple via cjoint.com .Nous pourrons mieux comprendre ton problème et t'aider.
Messages postés
63
Date d'inscription
mardi 7 mai 2013
Statut
Membre
Dernière intervention
23 avril 2020
1
https://www.cjoint.com/?3KtrBynu254
Voici, j'ai mis les zones qui m'interessent en jaune. Merci pour ton intéret!
Messages postés
127
Date d'inscription
dimanche 2 novembre 2014
Statut
Membre
Dernière intervention
20 janvier 2015
3
Voici la bonne formule:
En B26: =NB.SI('1F'!$J$9:$J$61;'Traitement RESTAU 1F'!A26)
Messages postés
63
Date d'inscription
mardi 7 mai 2013
Statut
Membre
Dernière intervention
23 avril 2020
1
Problème résolu! J'ai utilisé la méthode de R@chid sur un autre site dédié à Excel et aux Downloads , le sujet s'appelle Filtre auto et nb.si , ne sachant pas s'il est autorisé de partager des liens extérieurs à CCM je vais m'abstenir.
Messages postés
127
Date d'inscription
dimanche 2 novembre 2014
Statut
Membre
Dernière intervention
20 janvier 2015
3
OK tant mieux alors ;)
Messages postés
127
Date d'inscription
dimanche 2 novembre 2014
Statut
Membre
Dernière intervention
20 janvier 2015
3
En fait, ce que je ne comprend pas, c'est ton problème:
"En gros quand je filtre sur l'intitulé Normal je devrais obtenir ceci:

[NORMAL ][ 8] (le 8 est un exemple vous l'aurez compris)
[SANS SEL][ 0]

Et si je filtre sur l'intitulé Sans sel, je devrai avoir ceci:

[NORMAL ][ 0]
[SANS SEL][ 3] (là encore 3 étant un exemple) "


Je ne vois pas où tu veux filtrer.