Excel - fonction SI avec 3 conditions [Résolu/Fermé]

Signaler
-
Messages postés
25092
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
-
Bonjour,

je souhaite une formule avec la fonction "SI"
Si le résultat est compris entre 0 et 10 = 3€
Si compris entre 10 et 20 = 5€
Si compris entre 20 et 50 = 10€

merci de votre réponse :-)

2 réponses

Messages postés
25092
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 258
Bonjour

=SI(A1="";"";SI(A1<=10;3;SI(A1<=20;5;10)))

renverra 10 si A1 est plus grand que 50,

s'il y a risque écrire

=SI(OU(A1="";A1>50);"":SI(A1<=10;3;SI(A1<=20;5;10)))

qu ne renverra rien si A1 est vide ou >50

crdlmnt

Errare humanum est, perseverare diabolicum
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 92856 internautes nous ont dit merci ce mois-ci

Merci merci merci!!!!
:-)
Messages postés
25092
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 258
OK pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Messages postés
833
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 mai 2015
112
Bonjour,

Je ne vais pas te donner la réponse mais une explication pour que tu comprenne comment fonctionne les formules si

- il faut que tu vois la formule comme une phrase : SI machin est majeur ALORS il peut passer le permis SINON il ne peut pas

Les "alors" et "sinon" correspondent aux premier et deuxième ";"

traduit en formule excel sa donnerai : =Si(agemachin=18;"il peut passer le permis";"il ne peut pas")

Pour ton cas où il y a plusieurs condition tu peux te le traduire par un "SINON SI"

exemple :
Si machin a moins de 18 ans alors il est mineur
Si machin a 18 ans alors il est majeur en france
Si machin a 21 ans alors il a la majorité international

En formule excel sa donne :

=Si(agemachin<18;"il est mineur";si(agemachin<21;"majeur en france";"majorité international"))

Voila pour mon mini cours fait à l'arrache ^^

J'espère qu'il t'aidera a mieu comprendre le fonctionnement des formules si ^^

Bonne journée
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 92856 internautes nous ont dit merci ce mois-ci