Fonction Equiv avec 2 listes déroulantes

[Résolu/Fermé]
Signaler
Messages postés
2
Date d'inscription
mercredi 29 octobre 2014
Statut
Membre
Dernière intervention
30 octobre 2014
-
Messages postés
2
Date d'inscription
mercredi 29 octobre 2014
Statut
Membre
Dernière intervention
30 octobre 2014
-
Bonsoir ou bonjour à tous,

Je n'arrive pas à entrer la bonne formule en cellule G13 pour obtenir une formule qui détermine le tarif du concert en utilisant les nombres qui se trouvent dans les cellule D10 et D13 (par rapport à des listes déroulantes) !!! => Par rapport au fichier joint : https://www.cjoint.com/?0JDwwpKdakS

Pour ceux où le fichier ne s'ouvre pas : J'ai deux listes déroulantes qui sont rattachées à un tableau à double entrée, pour chaque liste j'ai une cellule liée où est rentré un nombre. Avec une formule je souhaiterais trouver en fonction des valeurs affichées dans les listes déroulantes, une valeur qui est le résultat du croisement entre les colonnes et les lignes du tableau à double entrée...

J'ai essayé une fonction équiv puis 2... J'ai essayé aussi =index(matrice;Equiv(D10;lignes;0);Equiv(D13;colonnes;0). Nada, rien...

Merci par avance de votre aide,

bien cordialement

3 réponses

Messages postés
13097
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2021
2 246
Bonsoir*

Dans l'onglet Tarif nommer la plage B2:D4 tarifs (selection plage clic droit Nommer plage)

Dans l'onglet Billets mettre à l'endrot désiré la formule :
=INDEX(tarifs;Billets!D10;Billets!D13)

Cdlmnt
Messages postés
17539
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 septembre 2021
4 733
Bonsoir,

Déjà évite de fusionner tes cellules difficile à gerer dans les formules

ensuite pourquoi utilises tu des zones combinées, utilise simplement des listes de validation en B3, en B10 et B13 (Données/Validation des données/Liste), à partir de là tu as plusieurs formules possible comme
=RECHERCHEV(B10;Tarifs!A1:D4;EQUIV(B13;Tarifs!A1:D1;0);0)
qui avec des plages nommées Tarifs!A1:D4 nommée Tarifs et arifs!A1:D1 nommée Place, pourrait devenir
=RECHERCHEV(B10;Tarifs;EQUIV(B13;Place;0);0)
ou
=INDEX(Tarifs!A1:D4;EQUIV(B10;Tarifs!A1:A4;0);EQUIV(B13;Tarifs!A1:D1;0))
qui avec des plage nommée pourrait devenir
=INDEX(Tarifs;EQUIV(B10;Type;0);EQUIV(B13;TPlace;0))

https://www.cjoint.com/?DJDxypVLg1m

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
2
Date d'inscription
mercredi 29 octobre 2014
Statut
Membre
Dernière intervention
30 octobre 2014

Merci beaucoup via55 et Mike-31, même si je n'ai pas appris comme ça, je comprends le pourquoi du comment ! C'est l'essentiel...

cdlmt