Formule

[Résolu/Fermé]
Signaler
Messages postés
140
Date d'inscription
lundi 16 novembre 2009
Statut
Membre
Dernière intervention
3 août 2017
-
Messages postés
140
Date d'inscription
lundi 16 novembre 2009
Statut
Membre
Dernière intervention
3 août 2017
-
Bonjour, je ne sais pas comment faire une formule, je suis très embêtée.
Voilà j'essaie de vous expliquer.
J'ai un fichier pour les horaires, j'aimerai trouver une formule pour que
dans la cellule aa75 j'ai mis les jour férié avec une formule, j'aimerai que quand le jour férié tombe dans les cellules" b71" a "h71" qu'il s'en lève automatiquement dans la cellule aa75 sachant qu' il y a des formule dans toute les cellules,
Si quel qu'un pourrais m'aider sa serai super.
Je vous envoie le fichier joint
Merci


https://www.cjoint.com/?3JxiPeAJu2y

7 réponses

Messages postés
17595
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 octobre 2021
4 776
Bonjour,

Je te conseille de revoir ta mise en forme afin de mettre tes jours fériés sur une seule colonne, regarde en Z75 à Z95 tu peux pour cela utiliser les cellules vide qui se trouvent jute au dessus à partir de Z67
ensuite dans la colonne AA je t'ai mis la formule pour éliminer le jour férié utilisé
=SI($Z76<>"";SI(NB.SI($B$71;$Z76)=1;"";$Z76);"")

https://www.cjoint.com/?DJxjzYYFA1O
Messages postés
140
Date d'inscription
lundi 16 novembre 2009
Statut
Membre
Dernière intervention
3 août 2017

un grand merci sa fonctionne super bien mais , si je veut récupérer le
le 5 avril a la date du 30 avril donc dans l onglet avril cellule e 57 comment je peut faire
https://www.cjoint.com/?3Jxkz49UxFp
Messages postés
17595
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 octobre 2021
4 776
Re,

Pas tout compris, mais ce que je te conseillais, la plage "liaison!$D$2:$D$17" tu la nommes exemple Fériés et ta formule en E56 comme dans toutes tes formules devient

=SI(NB.SI(Fériés;E53);1;"") à la place de =SI(NB.SI(liaison!$D$2:$D$17;E53);1;"")

c'est allègement multiplié par X fois va te permettre de gagner en taille ton fichier

ensuite en fonction de ce que je comprends, "si je veut récupérer le
le 5 avril a la date du 30 avril"

tu veux dire si précédemment tu as utilisé le 4 avril et tu veux de nouveau l'afficher, si c'est cela il suffit de rappeler ta plage nommée Fériés
et si ce n'est pas cela explique ce que tu veux faire
Messages postés
140
Date d'inscription
lundi 16 novembre 2009
Statut
Membre
Dernière intervention
3 août 2017

ré bonjour, je ne te comprend pas avec la plage liaison d2 à d17
je suis vraiment pas forte avec les formule.

par rapport au 4 avril je ne le note pas car je veut le récupérer plus tard par

exemple

mais j ai un onglet nommé férié avec tous les fériés
dans la colonne B ce sont les fériés , dans la colonne c ce sont les date des férié récupéré qui sont en liaison avec tous les mois.

par ex si je veut récupéré mon férié du 5/04 le 30 avril il se note dans la feuille férié.
mais j aimerai bien un genre de pense bête colonne z et aa , pour les férié qui ont déjà été pris, car j ai bc de tableau a faire , je sais je n arrive pas fort bien a m expliquée

https://www.cjoint.com/?3JxmlEgTjZj
Messages postés
17595
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 octobre 2021
4 776
Re,

La plage dont tu te sert dans tes formules Z19 à AA24 dans tous tes tableaux fait référence à ta plage onglet Liaison cellule D2 à D27 "liaison!$D$2:$D$17"
pas à l'onglet Férié.
C'est pour cela si tu nommes la plage "liaison!$D$2:$D$17" exemple Fériés, tes formules sur tous tes tableau en colonne E et j'avais pris E56 comme exemple deviendrait

=SI(NB.SI(Fériés;E53);1;"")

après pour ta question

par ex si je veut récupéré mon férié du 5/04 le 30 avril etc ... je ne comprends pas ce que tu cherches faire
Messages postés
140
Date d'inscription
lundi 16 novembre 2009
Statut
Membre
Dernière intervention
3 août 2017

Bonjour, je te dis encore je suis nul, mais j'essaie de me faire comprendre et je te remercie beaucoup pour ta patience.
Donc on départ je dois faire un outil de travail pour les horaire de 50 personnes.
Donc je cherche dans tous les forums et j i arrive, dans mon tableau j'ai beaucoup de liaison qui vont dans les autre fichier, ses pour cela que tu m'a dit que je devrais alléger mon fichier, mais je n'en suis pas capable.
Alors je reviens à ma question.
Certaine personne travaille les jours fériés donc je leur enlève et elle peuvent le récupérer plus tard.
Donc ses pour cela que j'aimerai que dans la colonne AA que les fériés pris s enlève et les autre reste comme sa quand la travailleuse vient faire ses horaire même 3 mois après je peux lui dire en regardant la colonne AA : exemple ( il te reste un férié a récupérer.)
Messages postés
140
Date d'inscription
lundi 16 novembre 2009
Statut
Membre
Dernière intervention
3 août 2017

Bonjour, Mike
mon problème est résolu
j ai utiliser ta première formule
=SI($Z76<>"";SI(NB.SI($B$71;$Z76)=1;"";$Z76);"")
j ai trouver ce qui n allais pas , je mettais les dates en 2014, alors qu elle devais être mise en 2015.
et sa fonctionne très bien.
merci a toi