Mise en forme conditionnelle sur une cellule avec formule [Résolu/Fermé]

Signaler
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015
-
 jeff -
Bonjour,

Je souhaite comparer le mois de la date d'une cellule avec le mois de la date la date du jour, pour une mise en forme conditionnelle.
seulement voila, la cellule à comparer contient une formule qui copie la date d'une autre page, et excel ne prend pas en compte la valeur affichée.

Ex A1 la formule =Saisie!B12. la valeur étant par ex 30/09/14.
Excel ne prend pas la date en compte. par contre si je la saisis, ça fonctionne.
Il doit exister kje pense une formule qui permette de prendre en compte la valeur et non la formule.

Merci de votre aide.

Bien cordialement,

9 réponses

Messages postés
15419
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
13 novembre 2020
1 395
Bonjour,

comment avez-vous fait votre mise en forme conditionnelle ??
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015

En fait je compare deux cellules à la date du jour, et la date des deux est copiée collée avec laison.

=Si($C1<=0;MOIS($A1)=MOIS(AUJOURDHUI());MOIS($C1)=AUJOURDHUI()))
et la mise en forme je veux la ligne en vert

Merci
Messages postés
15419
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
13 novembre 2020
1 395
Re,

ET a la place de SI dans votre formule magique pour la MFC
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015

Re

Non non la formule fonctionne sur un tableau ou je saisis les dates en A1 et C1.
Il n'y a que quand je mets une formule qui me "recopie" les dates où la mise en page ne fonctionne pas.
Je pense qu'il doit y avoir un moyen de demande à prendre en compte la valeur et non la formule.
Mais ça dépasse mes connaissances.
Merci
Messages postés
25546
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2020
5 597
Bonjour
si on s'en référe à votre premier message, on peut penser que la date dans la cellule mère n'est pas au format date d'Excel, mais est un texte.(En B12)
Pour vérifier formater la cellule en standard et voyez si la date se tranforme en nombre ou pas
Et si elle se transfgorme pasd, essayez ceci:
copiez une cellule vide
sélectionnez votre champ de dates défaillantes et collage spécial: "addition"

ou encore,peut être plus simplement, essayer avec =saisie!B12*1 pour numériser le résultat en A1

Mais il serait préférable de numériser vos dates pour l'ensemble de vos besoins!



crdlmnt
Messages postés
15419
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
13 novembre 2020
1 395
Bonjour,

en effet, c'est une possibilite.
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015

Bonjour,

Toutes mes cellules sont formatées en format date jj/mm/aa que ce soit en saisie!B12 ou en A1 et C1.
Je pense que c'est la formule en A1 et C1 qui perturbe le tout
ex en A1j'ai mis = saisie!B12 et en C1 j'ai mis =saisie!D12
du coup excel ne reconnait pas la date affichée dans A1 et C1 car il considère la formule je pense.

Merci
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015

Re,

Quand C1 affiche une date cela fonctionne. ce qui veut dire que dans ma formule =SI(C1<=0... il ne considère pas C1 vide du fait de la formule qui y figure (=saisie!D12).
Il faudrait que je puisse lui demander de considérer la valeur affichée en C1 et ne pas tenir compte de la formule...
Je ne sais pas si ça c'est possible...

Merci de me dire et merci d'avoir pris la peine de vous pencher sur ma question

Cdlt
Messages postés
25546
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2020
5 597
Vitre formule renvoie saisie!D12 mpar exemple, mais si Saisie!D12 est un texte, elle vous renverra un texte quel;que soit le format e la cellule qui la contient!
avez vous vérifié les D12 ect... à l'origine de votre formule?
Messages postés
66
Date d'inscription
mercredi 28 août 2013
Statut
Membre
Dernière intervention
7 mai 2015

Re,

Finalement j'ai trouvé une parade. J'ai créé une cellule cachée (H1) dans laquelle j'ai mis la formule suivante
=SI(saisie!D12<=0;saisie!B12;saisie!D12)
de cette manière je n'ai qu'une cellule de référence pour la mise en forme conditionnelle et saisie B12 et saisie D12 sont bien des valeurs saisies.
Donc quand saisie D12 est vide il n'y a aucune formule qui me parasite...
Du coup ma formule conditionnelle sur l'autre feuille devient
=MOIS(H1)=MOIS(AUJOURDHUI()) "alors en vert"
Merci de votre aide en tout cas.
cdlt
Messages postés
257
Date d'inscription
mercredi 22 août 2007
Statut
Membre
Dernière intervention
16 mars 2016
16
Bonjour à tous,

Ce post est celui qui se rapproche le plus de mon soucis qui est assez simple pour vous, j'espère en tous cas.

J'ai excel 2013.

Je souhaite mettre en rouge 2 cellules horizontales voisines et consécutive si et seulement si il y a la valeur 0 dans l'une et la lettre P dans l'autre.
Exple :
E5 = 0 et F5 = P, alors colorer la zone E5:F5 en rouge.

J'ai essayé avec la mise en forme conditionnelle. Elle impose que la zone d'application de la formule soit écrite avec le symbole $ alors je souhaite recopier cette formule au reste de mon tableau. Mais la mise en forme conditionnelle n'accepte pas de valeur relative (message reçu dans un message d'erreur).

Suis-je clair ? si oui quelqu'un peut-il me dépanner ?
Merci d'avance
Bonjour à tous,

En formule tout simplement :

=NON(ESTNA(NBCAR(FORMULETEXTE(A2))))

@+