Calcule du nombre d'enfant en fonction des dates de naissance

Résolu/Fermé
Laure K. - 7 oct. 2014 à 18:18
 Laure K. - 8 oct. 2014 à 14:01
Bonjour,

Je recherche une formulaire (en espérant qu'elle existe), pour m'informer du nombre d'enfants de plus de 20 ans en fonction de leur date de naissance et de la date du jour.

En résumé, en colonne A, B, C, D, E, F, il y a soit des dates de naissances soit des cellules vides (une ligne par famille avec dates de naissances) et j'aimerai qu'en fonction de la date du jour, Excel m'informe du nombre de cellule A, B, C, D, E, F dont la date de naissance selon la date du jour est supérieur à 20 ans.

Est-ce possible ?

Merci par avance pour votre précieuse aide et bonne soirée.

3 réponses

Mike-31 Messages postés 18049 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 septembre 2022 4 997
Modifié par Mike-31 le 7/10/2014 à 18:39
Bonsoir,

par exemple pour la plage A2:F20

=SOMMEPROD((A2:F20<=DATE(ANNEE(AUJOURDHUI())-20;MOIS(AUJOURDHUI());JOUR(AUJOURDHUI())))*(A2:F20<>""))

en plus tu pourrais ajouter une mise en forme conditionnelle pour coloriser la date en question

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Mike, définitivement you are the best :-) je ne sais pas d'où tu es, mais je te dois en tout cas une énorme boîte de chocolat pour ta précieuse aide ! je te l'envoi avec grand plaisir, si tu le désires, un petit geste pour un énorme merci.
0
Mike-31 Messages postés 18049 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 septembre 2022 4 997
Modifié par Mike-31 le 8/10/2014 à 08:27
Re,

Déjà ton retour est une satisfaction et je suis content de t'avoir aidé, si tes attentes sont satisfaites, je passe le statut de la discussion en résolu.
pour les chocolats tu en mets un dans la bouche et ferme les yeux en pensant à ton serviteur, mais il n'y a que les montagnes qui ne se rencontre pas, qui sait la vie est si bizarrement faîte et je bouge pas mal alors !
autrement je suis dans la région Toulousaine.

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
Tu as toujours répondu à mes questions et comme toujours, ça marche picco bello et le gain de temps est juste énorme, sans compter l'apprentissage de ce cher Excel, t'imagines pas le bonheur que c'est (oui, cette entre aide que vous faites me rend heureuse, dingue de trouver des gens qui ont encore cette valeur).

Merci d'avoir mis la question en "résolu".

Suis en Suisse, à 1 bonne heure de Genève (Fribourg), alors si une fois tu passes par là, n'hésite pas !

a+
0