Ne pas afficher de résultat quand cellule vide (date) [Résolu/Fermé]

Signaler
-
Messages postés
8
Date d'inscription
mercredi 14 mai 2008
Statut
Membre
Dernière intervention
14 janvier 2020
-
Bonjour,

Comment laisser un résultat vide lorsque la cellule de la formule est vide ?

Voici mon explication :
Je souhaite obtenir la date J+1 (sans compter les weekend) et laisser la cellule vide lorsqu'il n'y a pas de date renseignée.

Mon fichier ce présente ainsi :
colonne F => jour J
colonne G => J+1 sans les weekend

la formule est donc : si(JOURSEM(F3)=6);F3+3;F3+1)

ex : lorsque F2=10/09/2014 alors G2=11/09/2014
lorsque F3=12/09/2014 alors G3=15/09/2014 (car le 12 est un vendredi et que je cherche la date du jour ouvré suivant)

Jusque là tout vas bien :)

Mon problème c'est que lorsque la colonne F n'est pas renseigné, il y a tout de même un résultat qui s'affiche dans les cellules de la colonne G : 01/01/1900

Je sais que la formule/condition pour éviter cela ce serai un truc du genre : si(estvide(F3);"";
mais je n'arrive pas a fusionner mais 2 formules.... -_-'

J'ai essayé : =si(estvide(F3);"";(JOURSEM(F3)=6);F3+3;F3+1))
mais apparement il y a une erreur que je n'arrive pas a identifier

Pouvez-vous m'aider ?
J'utilise Excel 2003
Merci

4 réponses

Messages postés
25366
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Bonjour

manque un SI

=SI(ESTVIDE(F3);"";SI(JOURSEM(F3)=6;F3+3;F3+1))

crdlmnt

Errare humanum est, perseverare diabolicum
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 283
Bonjour,

Rajoute simplement une conditionnelle

=SI(F3="";"";SI(JOURSEM(F3)=6;F3+3;F3+1))
Messages postés
8
Date d'inscription
mercredi 14 mai 2008
Statut
Membre
Dernière intervention
14 janvier 2020

Merci pour vos réponse rapide
Messages postés
205
Date d'inscription
mercredi 2 mai 2012
Statut
Membre
Dernière intervention
26 juin 2015
75
Salut!

Essaye :

=SI(NB.VIDE(F3)=1;"";SI(JOURSEM(F3)=6);F3+3;F3+1))

ça devrait marcher!

En espérant avoir aidé :)