Calculer une somme en prenant que 2 lignes sur 3 [Résolu/Fermé]

Signaler
Messages postés
213
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
8 octobre 2019
-
Messages postés
213
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
8 octobre 2019
-
Bonjour,

Dans une colonne, j'ai des valeurs, mais je ne veux additionner que les valeurs des lignes 2,3, 5,6, 8,9, 11,12...

j'ai pensé à utiliser les fonction mod ou décaler, mais je n'y arrive pas.
Quelqu'un peut-il m'aider svp.
Merci

4 réponses

Messages postés
23404
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 mai 2020
6 169
Bonjour,

ou plus simplement en B4 (ou B3 ou ...) :
=SOMME(A2:A3)
et sélectionner B2:B4 avant de tirer vers le bas.

eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83650 internautes nous ont dit merci ce mois-ci

Messages postés
263
Date d'inscription
mardi 30 septembre 2014
Statut
Membre
Dernière intervention
22 février 2016
13
Messages postés
25111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 272
Bonjour
peut être avec cette formule pour un champ de valeurs de A2 à A100:

=SOMMEPROD(((MOD(LIGNE(A2:A100);3)=2)+(MOD(LIGNE(A2:A100);3)=0))*(A2:A100))

attention aux parenthèses

crdlmnt
Messages postés
213
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
8 octobre 2019
10
Bonjour Vaucluse et Eric,
Merci pour vos réponses ; elles m'interressent toutes les 2.
Par contre si Vaucluse pouvait m'expliquer comment il choisit =2 et =0, je pourrai réutiliser la formule avec d'autres intervalles.

encore une fois merci
Messages postés
25111
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 272
Bonjour

pour comprendre la formule, on décompose
SOMMEPROD fonctionne en matricielle (considère donc ligne par ligne) et n'additionne que les valeurs du second item (sans égalité) sur les lignes qui vont répondre aux conditions précisées dans le premier item, pour le champ indiqué

LIGNE() renvoie le N° de ligne où se trouve la formule
pour constater, écrire dans une cellule = LIGNE() et voir le résultat (le N° de ligne s'affiche)

MOD(valeur;diviseur) renvoie le reste de la division effectuée dans les parenthèses
pour constater, écrire =MOD(LIGNE();3) en B2 par exemple, et tirer vers le bas
les valeurs renvoyées se répètent en fonction du diviseur et du numéro de ligne

il suffit alors
dans le code MOD de placer le diviseur qui correspond à l'intervalle cherché
dans la formule SOMMEPROD d'additionner dans le premier item (l'item condition), les valeurs des résultats de MOD qui sont à retenir (chaque élément entre parenthèses et séparés par le signe +


à noter qu'en fait (après réflexion!!) on peut simplifier la formule en écrivant:

=SOMMEPROD((MOD(LIGNE(A2:A100);3)<>0)*(A2:A100))

ça devrait suffire pour éliminer du calcul les lignes ou MOD renvoie 0 , 3 étant la valeur du "pas" de l'addition

pas facile d'expliquer par écrit
en espérant avoir été clair

crdlmnt
Messages postés
213
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
8 octobre 2019
10
Très clair, merci beaucoup. Bonne journée