Regroupement de 2 tableaux excel avec une information commune

Fermé
13rems - 1 oct. 2014 à 09:51
via55 Messages postés 13976 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 4 décembre 2022 - 1 oct. 2014 à 13:15
Bonjour,

j'ai 2 tableaux excel que j'aimerai fusionner.
Ils ont tous les deux une inforamtion commune (le N°client) en 1ere colonne.
Dans les autres colonnes j'ai des informations différentes.

Le but serait de regrouper ces deux tableaux pour avoir les informations sur un meme document.

Les informations du deuxième tableaux serait à coller au niveau de la dernière colonne du 1er tableau.

Est-il possible de me guider dans cette démarche.

Merci pour vos retours.

1 réponse

via55 Messages postés 13976 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 4 décembre 2022 2 526
1 oct. 2014 à 13:15
Bonjour

Supposons que le 1er tableau a 5 colonnes : en A le n°, de B à E les infos et que le second tableau a 4 colonnes : en A le n°, de B à D d'autres infos
Les données dans les 2 tableaux commencent en ligne 2 après une ligne de titre

1° selectionner la plage entiere du second tableau de données de A2 à D n, clic droit Nomemr plage et la nommer par ex tablo

2° en F2 du 1er tableau mettre la formule : =RECHERCHEV(A2;tablo;2;0) puis en G2 =RECHERCHEV(A2;tablo;3;0) puis en H2 =RECHERCHEV(A2;tablo;4;0) puis en G2 qui vont successivement chercher les infos en colonne 2, 3 et 4 du second tableau sur la même ligne que le n° en A2

3° Etirer ces formules au bas du tableau

4° Copier tout ce nouveau tableau et le coller sur une nouvelle feuille par Collage spécial Valeurs uniquement

Cdlmnt
4