Formule SUMIFS avec liste menu déroulant

Résolu/Fermé
Signaler
Messages postés
10
Date d'inscription
vendredi 26 septembre 2014
Statut
Membre
Dernière intervention
8 octobre 2014
-
Messages postés
10
Date d'inscription
vendredi 26 septembre 2014
Statut
Membre
Dernière intervention
8 octobre 2014
-
Bonjour à tous,

je voudrais faire la somme des heures travaillées par discipline et par secteur avec 2 conditions:

1-si le gars a travaillé dans le secteur 121 - Garage
ET
2-si le gars était un électricien (3700 - Electrique)

alors, y additionner les heures entrées

Dans le cas qui nous concerne, j'aimerais que cette valeur soit affichée dans l'onglet "Resume"

J'ai essayé cette formule mais malheureusement, ca ne fonctionne pas et je ne comprends pas pourquoi:

=SUMIFS('Comparatif - Budget'!C3:C5,'Comparatif - Budget'!E3:E5,'Comparatif - Budget'!G3:G5,'Comparatif - Budget'!A3:A6,"121",'Comparatif - Budget'!D3:D5,'Comparatif - Budget'!F3:F5,'Comparatif - Budget'!H3:H5,"3710")


Donc techniquement, il faudrait que le chiffre 60 soit affiché.

Qlq1 sait pourquoi ca ne fonctionne pas?

Je vous ai mis le fichier excel en annexe

Merci beaucoup

6 réponses

Messages postés
10
Date d'inscription
vendredi 26 septembre 2014
Statut
Membre
Dernière intervention
8 octobre 2014

je semble avoir de la difficulté à y inclure mon fichier excel...ca marque "processing" sans arrêt.
Comment faire autrement?
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Bonjour

je n'ai pas la version anglaise mais deux options (en français dans le texte)
à partir de Excel 2007

=SOMME.SI.ENS(champ à sommer;Champ1;ref1;Champ2;Ref2)

ou sinon:

=SOMMEPROD((Champ1=Ref1)*(Champ2=ref2)*(Champ à sommer))

je vous laisse traduire, désolé

crdlmnt

ps: je n'ai pas la traduction de SOMME.SI.ENS, mais pour SOMMEPROD:

SUMPRODUCT


Errare humanum est, perseverare diabolicum
0
Messages postés
10
Date d'inscription
vendredi 26 septembre 2014
Statut
Membre
Dernière intervention
8 octobre 2014

merci Vaucluse,

c'est ca que j'ai essayé de faire mais sans succès

savez vous comment y inclure un fichier excel afin que vous puissiez y jeter un coup d'oeil?
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Déposez le fichier sur:
https://www.cjoint.com/
copier le lien donné par le site et revenez le coller ici.

mais vérifier peut être que les guillemets que vous avez placés pour encadrer les valeurs numériques dans votre formule ne posent pas de problème (ils transforment les valeurs en texte)

A+
0
Messages postés
10
Date d'inscription
vendredi 26 septembre 2014
Statut
Membre
Dernière intervention
8 octobre 2014

0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Vu la disposition de votre fichier, je en vois qu'un calcul champ par champ

=SOMMEPROD((A3:A6=122)*((D3:D6="3700")*(C3:C6)+(F3:F6="3700")*(E3:E6)+(H3:H6="3700")*(G3:G6)))



attention aux parenthèses

il serait plus propre je pense, de créer une base de données en continu avec
en colonne A: le code
en colonne B: le lieu
en colonne C: le nom
en colonne D: la discipline
en colonne E : le nombre d'heure

et le remplir ligne par ligne à chaque intervention, en répétant les noms , les lieux ect.

avec une telle base de données vous pourrez reconstruire ce que vous voulez comme tableau

car sinon, si vous avez beaucoup de monsieur X,Y,Z, la, formule va être coton

crdlmnt

Errare humanum est, perseverare diabolicum
0
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
;;; suite
voir ici la formule en K13
https://www.cjoint.com/c/DIAtT1HYlEJ
0
Messages postés
10
Date d'inscription
vendredi 26 septembre 2014
Statut
Membre
Dernière intervention
8 octobre 2014

un gros merci pour cette suggestion
en effet, votre proposition est de loin meilleure

encore merci! :)
0