Recherche formule [Résolu/Fermé]

Signaler
Messages postés
15
Date d'inscription
mercredi 10 septembre 2014
Statut
Membre
Dernière intervention
3 octobre 2014
-
Messages postés
15
Date d'inscription
mercredi 10 septembre 2014
Statut
Membre
Dernière intervention
3 octobre 2014
-
Bonjour,

je cherche la formule qui me fera gagnée du temps par rapport à la recherche ref/ref

je souhaite connaitre la quantité vendue sur la liste promo en comparaison de ma liste de vente genérale (exemple si dessous)

par avance merci
bonne journée à vous tous


feille 1 vente generale
ref design qte vendue
566830 12 R 22.5 0,00
566820 12 R 22.5 0,00
567280 13 R 22.5 44,00
567282 13 R 22.5 60,00
560532 13 R 22.5 151,00
560741 13 R 22.5 4,00
561501 205/75 R 17.5 14,00
558913 215/75 R 17.5 0,00
557843 215/75 R 17.5 16,00

feille 2 promo

ref design qte vendue

567280 13 R 22.5
567282 13 R 22.5
560532 13 R 22.5
560741 13 R 22.5
561501 205/75 R 17.5
558913 215/75 R 17.5
557843 215/75 R 17.5

5 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
494
Bonjour,

=RECHERCHEV(A2;'vente generale'!$A$2:$C$10;3;FAUX)

A+
Messages postés
15
Date d'inscription
mercredi 10 septembre 2014
Statut
Membre
Dernière intervention
3 octobre 2014

merci de votre reponse, mais je ne siais as la faire fonctionner!
seule la premiere ligne marche!
très cdlt
Messages postés
25461
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
5 565
Bonjour
la solution de Gyrus (salut) semble correcte, mais en fait, toutefois pouvez nous dire ce qui permet d'identifier les articles vendus en promo, vu que des références ont disparu entre vos deux tableaux?

crdlmnt
Messages postés
15
Date d'inscription
mercredi 10 septembre 2014
Statut
Membre
Dernière intervention
3 octobre 2014

bonjour vaucluse,

merci de me donner le moyen de vous envoyer le fichier

la premiere liste et le recapitulatif des ventes genérale du mois
la deuxieme etant la lites des promos

merci de m'expliquer le cheminement, car je vois ce que je veux faire mais n'arrive pas à le transcrire en langage excel

d'avance merci
Messages postés
25461
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
5 565
Déposer le sur:
https://www.cjoint.com/
et revenez ici coller le lien donné par le site
a+
crdlmnt
Messages postés
15
Date d'inscription
mercredi 10 septembre 2014
Statut
Membre
Dernière intervention
3 octobre 2014

vaucluse

ci dessous le lien

https://www.cjoint.com/?0IsqzqcWBhs

bonne reception et encore merci
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
494
Bonjour,

Voici une proposition à tester
https://www.cjoint.com/c/DIssfxCeCBh

A+
Messages postés
15
Date d'inscription
mercredi 10 septembre 2014
Statut
Membre
Dernière intervention
3 octobre 2014

Bonjour Gyrus,
la formule fonctionne !

merci !

très cordialement
Messages postés
25461
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
5 565
Bonjour
compte tenu du fait qu'à priori il peut y avoir,plusieurs fois la même référence dans le tableau Vente (ex ligne 17 et 19) , voyez la formule de la colonne C de Promo qui devrait faire ce que vous attendez.

Cette formule utiliser le code en A car le libellé n'est pas identique dans les deux feuilles en B.

https://www.cjoint.com/?DIssgomqRA6

Par ailleurs vous pouvez en B de promo, ressortir le nom de produit à partir de l'entrée du code en A, avec cette formule en B2 qui vous renverra le code exact placé en B de vente, à conditon qu'une vente aie été enregistrée (sinon cellule B reste blanche)
=SI(OU(NB.SI(vente!A:A;A2)=0;A2="");"";RECHERCHEV(A2;vente!A:B;2;0))
Errare humanum est, perseverare diabolicum
Messages postés
15
Date d'inscription
mercredi 10 septembre 2014
Statut
Membre
Dernière intervention
3 octobre 2014

bonjour Vaucluse,

la formule fonctionne aussi !
merci
très cordialement