Mettre un résultat automatique en fonction de la cellule d'avant

[Résolu/Fermé]
Signaler
-
Messages postés
454
Date d'inscription
mercredi 8 février 2012
Statut
Membre
Dernière intervention
13 août 2015
-
Bonjour,

Dans mon tableau Excel j'aimerai automatiser une cellule en fonction d'une autre. Je m'explique:

Si j'ai un résultat entre 0 et 50 dans B22, je veux que dans B23, il s'y inscrive 6€.
Si j'ai un résultat entre 51 et 100 dans B22, je veux que dans B23, il s'y inscrive 5,5€.
Si j'ai un résultat entre 101 et 150 dans B22, je veux que dans B23, il s'y inscrive 5€.
Si j'ai un résultat entre 151 et 200 dans B22, je veux que dans B23, il s'y inscrive 4,5€.
Si j'ai un résultat entre 201 et 250 dans B22, je veux que dans B23, il s'y inscrive 4€.

Si il y a une solution je suis prenneuse !
Je vous remercie d'avance,

Typhaine

1 réponse

Messages postés
454
Date d'inscription
mercredi 8 février 2012
Statut
Membre
Dernière intervention
13 août 2015
488
Bonjour,

Tu peux essayer ça en B23 :

=SI(ET(B22>0;B22<50);6;SI(ET(B22>51;B22<100);5.5;SI(ET(B22>101;B22<150);5;SI(ET(B22>151;B22<200);4.5;SI(ET(B22>201;B22<250);4;"")
Il me marque que la formule contient une erreur ! :/
Messages postés
454
Date d'inscription
mercredi 8 février 2012
Statut
Membre
Dernière intervention
13 août 2015
488
Essaye avec des virgules

=SI(ET(B22>0;B22<50);6;SI(ET(B22>51;B22<100);5,5;SI(ET(B22>101;B22<150);5;SI(ET(B22>151;B22<200);4,5;SI(ET(B22>201;B22<250);4;"")
Génial ça fonctionne ! Merci beaucoup !!!
Messages postés
454
Date d'inscription
mercredi 8 février 2012
Statut
Membre
Dernière intervention
13 août 2015
488
Mais il n'y a pas de quoi :)