Additionner sous excel un seul mot inclus dans le texte d'une ce

Résolu/Fermé
COACTION
Messages postés
6
Date d'inscription
mardi 22 juillet 2014
Statut
Membre
Dernière intervention
23 juillet 2014
- 22 juil. 2014 à 17:32
COACTION
Messages postés
6
Date d'inscription
mardi 22 juillet 2014
Statut
Membre
Dernière intervention
23 juillet 2014
- 23 juil. 2014 à 23:07
Utilisateur d'EXCEL 2103, je cherche la formule qui permettrait d'additionner le nombre de fois qu'un mot inclus dans le texte d'un ensemble de cellules d'une même colonne apparaît.
Exemple: Dans la colonne est inscrit dans chacune des cellules une date. Cette date peut varier d'une ligne à l'ordre. je voudrais pouvoir additionner toutes les dates d'un même mois indépendamment de l'indication du jour (toutes les dates du mois de juin puis de juillet, puis de septembre, etc... figurant dans cette colonne. dans la cellule la forme de la date est : mercredi 23 juillet 2014.

2 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 261
Modifié par Vaucluse le 22/07/2014 à 17:46
Bonsoir
s'il s'agit de totaliser le nombre de date d'un même mois, si les cellules sont bien dans un format date quel qu'il soit, mais pas en texte:
_pour une liste de la même année)
de A1 à A100

=SOMMEPROD((MOIS(A1:A100=1)*1)
et pmour pre,ndre aussi l'année en cours!:

=SOMMEPROD((ANNEE(A1:A100)=2014)*(MOIS(A1:A100)=1))

=1 pour janvier, 2 pour février ect..

Si par contre vos dates sont en texte

=NB.SI(A1:A100;"*Janvier*")

et NB.SI.ENS(A1:A100;"*Janvier*";A1:A100;"*2014*")

crdlmnt


Errare humanum est, perseverare diabolicum
0
COACTION
Messages postés
6
Date d'inscription
mardi 22 juillet 2014
Statut
Membre
Dernière intervention
23 juillet 2014

22 juil. 2014 à 22:22
Mes dates sont effectivement en texte par exemple "mercredi 23 juillet 2014". Cependant les 2 formules que vous me proposez (mois et/ou année) me donne un résultat à Zéro, alors qu'il y a dans 7 cellules de la colonne, sept dates contenant dans la colonne le mot juillet. Pour votre information je vais cherché les données sur un onglet du classeur différent de l'onglet où est effectué le calcul souhaité. la formule est : =NB.SI.ENS('Recueil des données'!I3:I600;"*juillet*";'Recueil des données'!I3:I600;"*2014*") = 0 au lieu de 7
0
Raymond PENTIER
Messages postés
56322
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 juillet 2022
17 211
Modifié par Raymond PENTIER le 22/07/2014 à 23:20
Bonjour.

J'ai essayé la formule : elle marche ! https://www.cjoint.com/?DGwxsl4ZfqG

Si tu envoies ton fichier, on va essayer de repérer ton erreur.
Pour cela, va dans https://www.cjoint.com/ pour créer le lien, que tu reviendras coller ici.

Cordialement.
0
COACTION
Messages postés
6
Date d'inscription
mardi 22 juillet 2014
Statut
Membre
Dernière intervention
23 juillet 2014

23 juil. 2014 à 12:13
Bonjour Raymond et merci. j'ai compris en partie pourquoi cela ne fonctionne pas. En effet, il s'agit de dates libellé en nombre qui se transforment en texte (exemple : 20/07/14 se transforme en mercredi 20 juillet 2014). Dans ce cadre j'ai fait un essaie avec la formule nombre de Vaucluse mais cela ne fonctionne pas non plus. Soit j'obtiens le résultat 4281 soit zéro. Comme indiqué je vous ai envoyé le fichier en utilisant Cjoint comme indiqué.
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 261
23 juil. 2014 à 12:18
Utiliser cjoint, c'est bien, mais il faut aussi copier le lien donné par le site et revenir le coller ici dans un nouveau message. Sinon non ne va pas le trouver!
à vous lire
0
COACTION
Messages postés
6
Date d'inscription
mardi 22 juillet 2014
Statut
Membre
Dernière intervention
23 juillet 2014

23 juil. 2014 à 12:21
nouvelle utilisateur de comment ça marche je ne comprend la notion de "copier ici"...c'est où ici dans un nouveau message ?
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 261
23 juil. 2014 à 07:27
Bonjour
L'onglet n'est pas en cause
Voyez ce modèle peut vous aider
Vérifier bien que votre format est bien texte . Vous pouvez par exemple formater en standard pour voir si les dates se transforment en valeur numérique (voir dans le modèle la colonne D en formatée en num devient colonne G)
https://www.cjoint.com/?DGxhw4NuXuD

et revenez avec un bout de fichier dans lequel vous collez votre liste à compter si ça ne convient pas

crdlmnt


0