EXCEL 4 SI

Résolu/Fermé
Messages postés
4
Date d'inscription
dimanche 20 juillet 2014
Statut
Membre
Dernière intervention
20 juillet 2014
-
Messages postés
4
Date d'inscription
dimanche 20 juillet 2014
Statut
Membre
Dernière intervention
20 juillet 2014
-
bonjour,
je cherche a donner a une cellule le nom d'une couleur qu'elle irait chercher dans une autre cellule.

J'ai essayé cette formule et d'autres mais sans succès:
=SI(a2<6;"vert";SI(a2<11;"bleu";SI(a2<15="jaune";"rouge")))

trouvé sur le forum:
=SI(B5=1;"A";SI(B5=2;"B";SI(B5=3;"C";SI(B5=4;"D";""))))

une aide serait très appréciée, merci pour la contribution

7 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
525
Bonjour,

=SI(A2<6;"vert";SI(A2<11;"bleu";SI(A2<15;"jaune";"rouge")))

A+
Messages postés
26411
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
6 193
Bonjour
*il faut utiliser la mise en forme conditionnelle
exemple si vous voulez traiter avec valeur de A1
sélectionnez la cellule ou le champ à traiter

ensuite:
_Ruban / onglet / Accueil/
_paragraphe style / Icone "mise en forme conditionnelle
_dans le menu affiché, sélectionnez "nouvelle règle)

s'affiche une fenêtre dans la quelle vous sélectionnez la ligne
_"utiliser une formule pour...."

fenêtre suivante
_entrez la formule, soit
=$A1<6
_cliquez sur format/formatez avec la couleur voulue / OK

_vous revenez à la fenêtre de MFC
_cliquez sur "nouvelle fenêtre"
et recommencez avec =$A1<10 ou autre ect....

si vous utilisez <, classez bien les MFC du plus petit au plus grand avec les flêches ascenseur dans la fenêtre de MFC
si vous traitez un champ, la formule à entrer et celle qui correspond à la 1° cellule en haut à gauche du champ, le reste s'ajuste
_avec les valeurs en colonne si vous utilisez =A1<xx
_avec les valeurs en ligne avec =A$1<xx
_avec la valeur de A1 si =$A$1<xx

crdlmnt


Messages postés
4
Date d'inscription
dimanche 20 juillet 2014
Statut
Membre
Dernière intervention
20 juillet 2014

Merci pour vos réponses:

Gyrus, ta formule ne convient pas, voici le résultat

A2 B2 C2 D2 E2 F2
1 6 11 16 17 15 vert vert bleu jaune rouge rouge

cellule B2= 6= vert alors que je veux "bleu"
C2 D2 E2 F2 pas bonnes non plus
==================================
vaucluse, la mise en forme conditionnelle fonctionne très bien pour mettre du vert dans une cellule dont le contenu est inférieur a 6, ce qui est le cas sur mon classeur excel: exemple la cellule A2 < 6 se retrouve bien en vert. Ce que je recherche c'est qu'une autre cellule (disons H6) m'écrive que que A2 est vert, ce qui est possible avec la fonction "SI" que j'utilise régulièrement a 1,2 ou 3 conditions, mais la je bute car 4 couleurs donc 4 conditions


Je suis désolé pour les réponses tardives mais j'ai aussi depuis hier des problèmes de déconnexion plus ou moins longs chez free. Il n'y a pourtant ni orage ni perturbations atmosphériques notable autour de mon domicile


je voudrais mettre une partie de mon classeur en piece jointe. Est-ce possible?
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
525
Je ne comprends pas ton résultat.
Voici un fichier exemple
https://www.cjoint.com/c/DGul6yWakuD

NB :Je n'ai pris en compte ton image que je ne suis pas parvenu à lire.

A+
Messages postés
4
Date d'inscription
dimanche 20 juillet 2014
Statut
Membre
Dernière intervention
20 juillet 2014

un peu long, désolé mais j'ai simplifié mon classeur, mis quelques explications et toujours mes problèmes de connexion qui n'arrangent rien.
voici le lien pour le classeur, merci encore a vous

https://www.cjoint.com/?DGunlBtALv5
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
525
Messages postés
4
Date d'inscription
dimanche 20 juillet 2014
Statut
Membre
Dernière intervention
20 juillet 2014

impeccable, pile poil, ça fonctionne très bien, merci a vous Gyrus pour cette solution adéquate et merci a Vaucluse