Fonction "si" à trois conditions [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
vendredi 13 juin 2014
Statut
Membre
Dernière intervention
13 juin 2014
-
Messages postés
25627
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 novembre 2020
-
Bonjour,
Je cherche comment faire sur excel une condition à trois entrées.
En gros si c'est possible de simplifier ce que j'ai fait (qui ne fonctionne pas d'ailleurs si vous pouviez me dire pourquoi) pour que dans la case du gagnant il y est écrit "A" si il a plus de point que B et K, "B" pour B>K et B>A et enfin de même pour "K" si K>A et K>B

Sachant que le résultat de B6 est "A" alors que c'est le K qui devrait s'afficher.
Merci.

2 réponses

Messages postés
569
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
7 mai 2015
64
Bonjour,

teste cela :

=Si(B2>C2;si(B2>D2;"A";"K");si(C2>D2;"B";"K"))

Cette formule ne gère pas si 2 cases sont égales.

Je n'arrive pas a voir ta formule. Peux tu l'écrire dans le message suivant stp ?
Messages postés
2
Date d'inscription
vendredi 13 juin 2014
Statut
Membre
Dernière intervention
13 juin 2014

Ah bien ta formule me convient totalement. Sinon la formule que j'avais bidouillé était
=SI(B2>C2>=D2;"A";SI(B2>D2>=C2;"A";SI(C2>B2>=D2;"B";SI(C2>D2>=B2;"B";SI(D2>B2>=C2;"K";SI(D2>C2>=B2;"K"))))))
Oui je sais c'est très laid et peu compréhensible :p
Messages postés
569
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
7 mai 2015
64
En effet, c'est un peu lourd comme formule :)

SI B2>C2 alors il faut comparer B2 à D2 si B2>D2 donc c'est B2 le plus grand.
Sinon ca veut dire que D2>B2 et donc D2>B2>C2 donc D2 le plus grand... etc

Pour faire des si imbriqués, il faut bien reflechir et ne pas hésiter à prendre un papier pour bien disocier les différents cas.
Messages postés
25627
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 novembre 2020
5 628
Bonjour

votre question ne dit pas ce qu'il faut faire avec des exaequo en tête de résultat

donc en supposant qu'il n'y en a pas:(???)

écrivez simplement A,B,K dans les cellules ,C,D1

la formule:

=INDEX($B$1:$D$1;;EQUIV(MAX($B$2:$D$2);$B$2:$D$2;0))

attention aux signes aux bons endroits

vous donnera le résultat en vous renvoyant ce qui est écrit en ligne 1 dans la colonne ou se trouve le maxi de la ligne 2

crdlmnt