Problème recopie vers le bas formule NB.SI

Résolu/Fermé
Grenadian Messages postés 55 Date d'inscription mercredi 7 mai 2014 Statut Membre Dernière intervention 28 juin 2017 - 23 mai 2014 à 14:08
Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 - 23 mai 2014 à 14:57
Bonjour,

J'ai une base de données très grande (8000 lignes). J'ai utilisé la formule NB.SI pour savoir combien de fois une valeur apparaît dans mon tableau.

Cela fonctionne, mais quand je recopie vers le bas, le nombre s'affiche à nouveau.

Admettons :
carole 3
sophie 1
thomas 1
carole 3
carole 3

Je voudrais que le nombre s'affiche une fois pour toute sur une valeur (ici, que le "3" de carole ne s'affiche que sur la ligne 1 et pas aux lignes 4 et 5).

J'espère me faire comprendre,

Merci d'avance !

3 réponses

Benoit A. Messages postés 454 Date d'inscription mercredi 8 février 2012 Statut Membre Dernière intervention 13 août 2015 512
23 mai 2014 à 14:21
Quelle est ta formule ?
0
PHILOU10120 Messages postés 6190 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 19 janvier 2023 753
23 mai 2014 à 14:47
Bonjour

Essayez ceci

=SI(NB.SI(A1:$A$8912;A1)=NB.SI($A$1:$A$8912;A1);NB.SI(A1:$A$8912;A1);"")
0
Grenadian Messages postés 55 Date d'inscription mercredi 7 mai 2014 Statut Membre Dernière intervention 28 juin 2017 2
23 mai 2014 à 14:53
Ça marche ! Génial !

Un grand merci !
0
Mike-31 Messages postés 18177 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 29 janvier 2023 5 033
Modifié par Mike-31 le 23/05/2014 à 14:59
Bonjour,

en supposant que tes articles sont en colonne A à partir de A2, exemple de formule à placer dans une cellule sur la deuxième ligne et incrémenter vers le bas

=SI(NB.SI(DECALER($A$1;0;0;LIGNE()-1);DECALER($A$1;LIGNE()-1;0))>0;"";NB.SI($A$2:$A$8000;A2))

ensuite d'autre possibilités, créer une liste sans doublons et appliquer en face chaque article le Fonction =NB.SI($A$2:$A$8000;cellule critère) et incrémenter vers le bas

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0