RechercheV avec une cellule texte excel 2010 [Résolu/Fermé]

Signaler
Messages postés
40
Date d'inscription
mardi 18 septembre 2007
Statut
Membre
Dernière intervention
25 avril 2017
-
Messages postés
17302
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 avril 2021
-
bonjour,

quelle est la formule exacte qui me permettrait de trouvé des informations dans un tableau transformé en matrice, lorsque dans la cellule j'inscrit du texte et non un chiffre.

exemples =RECHERCHEV(D50;POE;1;faux) la cellule D50 contient le texte ELBEUF et elle devrait me donnée le résultat suivant 9379 qui se trouve dans la matrice POE. malheureusement le résultat est #N/A

par contre si j'utilise la même formule et que dans la cellule D50 je met 9379 il me donne le résultat ELBEUF.

merci par avance.

bien cordialement
A voir également:

8 réponses

Messages postés
25949
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 865
Bonjour

votre formule est assez curieuse telle que présentée

elle va ressortir la valeur trouvée dans la colonne 1 correspondant à la valeur cherchée dans la même colonne?
La formule vous renverra D50 si la valeur de D50 existe dans la 1° colonne de POE et surement pas 9379!

On ne voit pas trop l'utilité, sauf bien sur si vous cherchez à ressortir un texte complet contenant la valeur cherchée
auquel cas la formule s'écrit:

=RECHERCHEV("*"&D50&"*";POE;1;faux)

cette configuration peut aussi permettre de s'affranchir de blanc qui pourraient exister avant ou après les textes dans les cellules cherchées

crdlmnt
Messages postés
325
Date d'inscription
dimanche 12 mai 2013
Statut
Membre
Dernière intervention
29 octobre 2020
3
C'est bien de joindre ton fichier en allant dans le site cijoint et de poster ensuite le lien afin qu'on puisse t'aider!!
Messages postés
53597
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
15 635
Remplace 1 par 2.
Messages postés
40
Date d'inscription
mardi 18 septembre 2007
Statut
Membre
Dernière intervention
25 avril 2017

Bonjour,

déjà merci pour vos réponses, vous trouverez ci-dessous le lien avec le document Excel. les formules sont sur l'index Planning.

https://www.cjoint.com/?3Eoij6fP64g

merci par avance et bonne journée.

bien cordialement
Messages postés
25949
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
9 avril 2021
5 865
Bonjour
vu le fichier
vous ne pouvez pas utiliser le code recherche pour ressortir une valeur de la 1° colonne à partir d'une cherchée dans la 2°!! RECHERCHEV ne cherche que dans la 1° colonne du champ pour envoyer ce qu'il y a dans les suivantes selon le N°
alors soit vous les colonnes de la feuille répertoire, soit vous utilisez en C5 cette formule:

=SI(D5="";"";SI(NB.SI('Repertoire Client'!B:B;"*"&D5&"*");INDEX(POE;EQUIV("*"&D5&"*";'Repertoire Client'!B:B;0);1);"non trouvé"))

crdlmnt

Ps pour éclaircir, vous pouvez aussi nommer le champ B:B de répertoire sur la même hauteur que POE

Errare humanum est, perseverare diabolicum
Messages postés
40
Date d'inscription
mardi 18 septembre 2007
Statut
Membre
Dernière intervention
25 avril 2017

merci beaucoup

cela fonctionne.

bonne journée

cordialement
Messages postés
17302
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 avril 2021
4 545
Re,

Si j'ai bien compris, autre possibilité, comme tu as déjà nommé la plage feuille Repertoire Client A1:B299 POE, nomme la plage B2:B299 exemple Libel (abréviation de Libellé)

Onglet Planning cellule C5 colle cette formule et incrémente vers le bas
=INDEX(POE;EQUIV(D5;Libel;0);1)

les cellule non renseignée afficheront le message d'erreur #N/A

pour éviter cela complète la formule en C5 comme ci-dessous et incrémente vers le bas

=SIERREUR(INDEX(POE;EQUIV(D5;Libel;0);1);"")

Attention si tu utilises le joker "*" exemple pour
PARIS 22 Banque - IMMEUBLE
PARIS Jaucourt
PARIS Opera (CAF)
PARIS Opera (CAF)

avec cette formule, sortira la première valeur 6111 il conviendra donc d'adapter une formule pour extraire toutes les valeurs associées
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
17302
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 avril 2021
4 545
Bonsoir,

Si la formule te retourne #N/A c'est que la valeur recherchée n'existe pas, que la cellule critère D50 est vide ou encore ta matrice est mal nommée.

Donc sans voir ton fichier, difficile de te donner une réponse précise. Si tu veux mettre à notre disposition ton fichier anonymisé utilise ce lien

https://www.cjoint.com/

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.