Disque dur IDE en NTFS détecté par windows mais pas par ubuntu

Résolu/Fermé
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 - 10 mai 2014 à 21:51
 Utilisateur anonyme - 16 mai 2014 à 15:36
Bonjour,

Je suis débutant sur Ubuntu, je viens de l'installer et j'ai un de mes Disques durs en NTFS que n'est absolument pas reconnu par mon Ubuntu 14 alors qu'il affiche d'autres partitions sur un autre disque dur en NTFS, le disque du marche en IDE et fonctionne parfaitement bien sous Windows 7 et 8.1.

Merci d'avance pour votre aide !

A voir également:

11 réponses

jeanbi Messages postés 15118 Date d'inscription samedi 9 décembre 2006 Statut Contributeur Dernière intervention 6 février 2023 2 177
11 mai 2014 à 09:06
bonjour,
dans un terminal
que renvoi la commande
fdisk -l   (l=L)

et

blkid
a+
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
11 mai 2014 à 09:53
Et quand je fait fdisk -l :

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 têtes, 63 secteurs/piste, 30401 cylindres, total 488397168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0xdfc5dfc5

Périphérique Amorçage Début Fin Blocs Id. Système
/dev/sda1 * 2048 190804004 95400978+ 7 HPFS/NTFS/exFAT
/dev/sda2 190804011 407235687 108215838+ 7 HPFS/NTFS/exFAT
/dev/sda3 407236606 488392064 40577729+ f Étendue W95 (LBA)
/dev/sda5 445482513 488392064 21454776 1 FAT12
/dev/sda6 407236608 441292799 17028096 83 Linux
/dev/sda7 441294848 445480959 2093056 82 partition d'échange Linux / Solaris

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Pas de trace de "sdb" donc il ne trouve pas mon disque IDE !

Et pour blkid c'est pareil, pas de "sdb" :

/dev/sda1: UUID="8EDAFE79DAFE5D41" TYPE="ntfs"
/dev/sda2: UUID="140CF1F40CF1D12A" TYPE="ntfs"
/dev/sda6: UUID="7fd1bc7a-176b-487c-87a5-2f718b7b18a7" TYPE="ext4"
/dev/sda7: UUID="c2545f3f-3830-44b0-b8f0-8975527f22f3" TYPE="swap"

ET si je déplaçai le petit cavalier sur mon disque dur IDE en master car là il est en slave ?
0
jeanbi Messages postés 15118 Date d'inscription samedi 9 décembre 2006 Statut Contributeur Dernière intervention 6 février 2023 2 177
11 mai 2014 à 10:03
bonjour,
pourquoi tu modifie quelque chose pour aller sur linux ou sur windows
a+
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
11 mai 2014 à 10:34
non je ne touche a rien !
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 409
11 mai 2014 à 10:14
Salut,

Peux-tu nous faire un screenshot de ton gestionnaire de disque sous Windows ?

Il y a quand même un truc qui me chiffonne dans le résultat de ton
fdisk
:
/dev/sda5 445482513 488392064 21454776 1 FAT12 
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
11 mai 2014 à 10:21
oui moi aussi je trouve ça bizarre il me semble Windows me dit que c'est une partition non formaté .....
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
11 mai 2014 à 10:37
Voila ce que dit Windows :

http://image.noelshack.com/fichiers/2014/19/1399797298-capture.png

C'est le bordel !
0
le druide Messages postés 40156 Date d'inscription vendredi 16 avril 2004 Statut Contributeur Dernière intervention 15 octobre 2023 6 606
12 mai 2014 à 18:23
lorsque tu boot sur Ubuntu, est-il bien monté ce disque dur IDE ?
0
Salut,

Il y a un problème sur le disque 0: on compte 4 partitions principales + 1 cinquième (étendue) passée en raw... Ca ne peut pas fonctionner correctement. C'est même étonnant que le système démarre toujours.
0
le druide Messages postés 40156 Date d'inscription vendredi 16 avril 2004 Statut Contributeur Dernière intervention 15 octobre 2023 6 606
Modifié par le druide le 12/05/2014 à 22:25
une partition logique en raw n'empèche en rien le démarrage du système et son bon fonctionnement.
0
Si la partition est passée en raw, c'est que la table de partitions est défaillante, d'une manière ou d'une autre. Ce n'est pas la partition en raw qui pose problème en soi, mais la table elle-même.

C'est d'ailleurs visible grâce à fdisk qui détecte une partition étendue (W95 ??? ) englobant trois partitions logiques (dont une en un surprenant fat12), alors que W7 ne voit qu'une partition étendue avec une seule partition logique (qu'il voit, lui, en raw). Les deux OS définissent la table de partitions différemment car elle pose un problème à chacun.

Certes, W7 affiche souvent en mode graphique des choses bizarres lorsque les partitions Linux sont présentes. Un diskpart / list disk / list partition serait plus précis, et si le partitionnement est bon, on doit arriver à quelque chose de ce genre:

DISKPART> list partition

N° partition Type Taille Décalag
------------- ---------------- ------- -------
Partition 1 Principale 100 M 1024 K
Partition 2 Principale 147 G 101 M
Partition 3 Principale 63 G 147 G
Partition 0 Étendu 21 G 211 G
Partition 4 Logique 7865 M 211 G
Partition 5 Logique 12 G 218 G
Partition 6 Logique 1881 M 231 G

à comparer à fdisk

sudo fdisk -l

Périphérique Amorçage Début Fin Blocs Id. Système
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 310216703 155004928 7 HPFS/NTFS/exFAT
/dev/sda3 310216704 443041791 66412544 7 HPFS/NTFS/exFAT
/dev/sda4 443041792 488396799 22677504 5 Étendue
/dev/sda5 443043840 459151359 8053760 83 Linux
/dev/sda6 459153408 484542463 12694528 83 Linux
/dev/sda7 484544512 488396799 1926144 82 partition d'échange

Ici, la structure est correcte. W7 n'a aucune raison de voir un volume en raw (les partitions Linux sont bien incluses dans la partition étendue selon les deux OS et tout apparaît dans l'ordre),

Dans le cas qui nous occupe, une vérification de cette table via diskpart, puis éventuellement avec tesdisk serait la bienvenue pour vérifier, et si besoin, remettre les choses d'aplomb, et ensuite, je ne serai pas surpris que le disque 1 (ou sdb) apparaisse comme par enchantement sous Linux.

Mais, dans tous les cas, le fait que la table de partitions du disque système soit défaillante entraîne très souvent des pannes au démarrage ("no system disk" notamment).
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46 > le druide Messages postés 40156 Date d'inscription vendredi 16 avril 2004 Statut Contributeur Dernière intervention 15 octobre 2023
13 mai 2014 à 07:09
Non je ne pense pas car ubunutu ne le reconnaît absolument pas!
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
Modifié par jujulechti le 13/05/2014 à 16:25
Test sous Ubuntu avec le disque dur INTERNE IDE branché : (sudo dmesg | tail-20)

ubuntu@ubuntu:~$ sudo dmesg | tail -20
[ 86.846254] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 86.846256] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 86.846258] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 86.846259] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 99.148041] usb 1-3: reset high-speed USB device number 4 using ehci-pci
[ 99.290570] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 3070, rev 0201 detected
[ 99.318699] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 0005 detected
[ 100.021588] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 100.022871] usbcore: registered new interface driver rt2800usb
[ 103.516473] init: alsa-restore main process (1828) terminated with status 99
[ 106.443553] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
[ 106.895478] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29
[ 107.243072] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 107.243900] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 107.247278] 8139too 0000:02:06.0 eth0: link down
[ 107.247370] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 107.247745] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 121.504594] init: plymouth-upstart-bridge main process ended, respawning
[ 121.529953] init: plymouth-upstart-bridge main process (2275) terminated with status 1
[ 121.529985] init: plymouth-upstart-bridge main process ended, respawning

Et le disque dur interne n'est TOUJOURS PAS détecté !!!
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
13 mai 2014 à 16:40
Et avec Diskpart sous windows :


DISKPART> select disk 0

Le disque 0 est maintenant le disque sélectionné.

DISKPART> list volume

N° volume Ltr Nom Fs Type Taille Statut Info
---------- --- ----------- ----- ---------- ------- --------- --------
Volume 0 J Ubuntu 14.0 CDFS DVD-ROM 4482 M Sain
Volume 1 D NTFS Partition 90 G Sain
Volume 2 C NTFS Partition 103 G Sain Démarrag
Volume 3 F RAW Partition 20 G Sain
Volume 4 E Téléchargem NTFS Partition 111 G Sain Système
Volume 5 G Amovible 0 o 0 média
Volume 6 H Amovible 0 o 0 média
Volume 7 I Amovible 0 o 0 média
Volume 8 K Amovible 0 o 0 média
Volume 9 L Amovible 0 o 0 média

DISKPART> list partition

N° partition Type Taille Décalage
------------- ---------------- ------- --------
Partition 1 Principale 90 G 1024 K
Partition 2 Principale 103 G 90 G
Partition 0 Étendu 38 G 194 G
Partition 4 Logique 16 G 194 G
Partition 5 Logique 2044 M 210 G
Partition 3 Logique 20 G 212 G

Le volume est le disque dur INTERNE ide en question ! et pourquoi il est "système" alors que si je le débranche, Windows se démarre correctement ? Bref .. au niveau des partition c'est le bordel !!!!
0
Si le live-cd ne voit pas non plus le disque dur E, le problème vient de ce disque lui-même (ta partition raw pourra être traitée plus tard, car le diskpart est plutôt rassurant) .

Pourquoi est-il bootable (je vois qu'il est actif)? As-tu un système installé dessus ? Son contenu est-il accessible depuis Windows ? Peux-tu nous en faire un court historique ?

(ton Ws démarre normalement parce qu'il est en priorité dans l'ordre de boot... si tu permutes, c'est ce disque qui prendra la main)

Car cette histoire devient très énigmatique, surtout si c'est un disque dur ide.

PS... les logiciels type "partition master" ne sont pas indispensables, tant avec W7 qu'avec ubuntu qui savent très bien faire les choses eux-mêmes, et de manière plus fiable.
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
Modifié par jujulechti le 13/05/2014 à 20:27
Bon, le disque dur IDE est non reconnu par Ubuntu mais il marche très bien sous Windows, auparavant je n'avais jamais eu de souci avec lui, sous Windows je peux accéder a son contenu mais pas sous Ubuntu, même sous le live-cd. Ce disque contient des films, logiciel, jeux et il ne contient AUCUN systeme d'exploitation. Je peux démarrer tous mes systèmes d'exploration sans lui, même Windows 8 ! IL ne contient aucun fichier nécessaire au fonctionnement de Ubuntu et Windows et il n'est pas bootable.
0
Ah si, il est bootable (ce qui ne signifie pas qu'il possède un OS).

http://image.noelshack.com/fichiers/2014/19/1399797298-capture.png

Le mot "actif" sur ce disque signifie activé pour booter. Enlève le caractère "actif " sur ta partition D (faisable très simplement par clic droit, mais je te le déconseille) et tu verras si ton seven boote encore.

Quant à ton problème de disque non reconnu par Linux, ça devient énigmatique. Perso, je n'ai plus d'idée. Tu dis qu'avant, il fonctionnait. Qu'as-tu fait avant que ce problème ne survienne ?
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46 > Utilisateur anonyme
13 mai 2014 à 21:59
Non il n'a jamais fonctionné sous Linux mais il a toujours marché sous windows . J'ai réessayé de faire sans le disque dur ide non reconnu par Linux mais depuis windows ne démarre plus, quand je démarre le Pc, il boot direct sur ubuntu sans rien le demander et quand je fait une réparation du démarrage à partir du DVD d'installation de windows 8 il dit qu'il n'y a pas de problèmes au niveau du démarrage donc ubuntu fonctionne mais pas windows maintenant ....
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46 > jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014
13 mai 2014 à 22:05
Comment je pourrai réparer ma bêtise ? En plus je ne connait pas de logiciels comme Easy bcd sur Linux !
Je n'ai toujours pas compris comment installer des logiciel avec le système des apt ! Je suis dans la Mouïse ......
0
Salut ;)

As tu essayé avec un autre live cd genre "Knoppix" pour voir si il détecte ton DD ide?

@++
0
Re,

J'interviens une ultime fois dans ce sujet, vu que ça devient cacophonique, et je ne veux pas rendre le sujet illisible.

Reprenons point par point les remarques du druide.

1. D'accord avec le druide, le loader semble être sur le disque 1 (bien que le disque 0 doive booter avant le 1, en toute logique). Ca explique en tout cas pourquoi le disque est actif.

2. "Le déballage de théories" reste d'actualité pour la partition passée en raw. Il faudra résoudre cela tôt ou tard.

3. Pourquoi repartir de zéro? Il suffit de réparer le démarrage du disque zéro et Windows repartira. Ensuite, il suffira de réinstaller grub pour retrouver le double boot. Et la seule partition apparemment inutile est celle passée en raw.

4. Ca n'a pas d''influence, puisque les deux systèmes fonctionnent.

5. Ce genre d'installation oblige à passer par le bios ou par le boot menu (faisable, mais un peu galère tout de même). Et franchement, grub est tout de même connu pour sa stabilité.

Quant au reste, c'est une affaire de goût.

************************************
Moi, je ferais les choses ainsi (mais chacun est libre et majeur). Je débrancherais le disque "téléchargements" pour éviter les surprises.

A. Réparation du mbr et du bcd du disque 0, en invite de commandes, depuis le DVD W7 ou W8:

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

+ 1 réparation automatique avec la première option et mes deux Ws doivent démarrer tout seuls.

B. Réparation de grub depuis le live-cd en suivant la méthode avec chroot proposée ici

http://doc.ubuntu-fr.org/tutoriel/comment_restaurer_grub

(ce qui donne, sauf erreur... zipe31 me corrigera si j'ai fait une gaffe dans le code)

sudo mount /dev/sda6 /mnt 
for i in /dev /dev/pts /sys; do sudo mount -B $i /mnt$i; done
sudo mount -t proc /proc /mnt/proc
sudo chroot /mnt /bin/bash
mount -a
apt-get install grub-pc
update-grub
grub-install /dev/sda (ou grub-install --force /dev/sda)
umount -a
sudo umount /mnt/{dev/pts,dev,sys,proc}
sudo umount /mnt
sudo update-grub (pour être sûr).

Là, je dois avoir un disque dur qui fonctionne seul, et avec les trois OS.

C. Désactivation du boot sur le disque 1.

Débranchement du disque qui est dépanné, branchement de l'autre. Avec l'invite de commande de W7 ou W8 (le DVD)

diskpart
select disk 0
select partition 1
inactive
exit

Le disque n'est plus bootable.

D. Je rebranche les deux disques, en mettant en priorité dans le bios celui qui possède les trois OS.

a). Je supprime la partition raw via diskpart

diskpart
select disk 0
select partition 6
delete
exit

b) Je lance mon Linux pour vérifier s'il détecte le second disque dur. Si oui, l'affaire est réglée. J'en profite pour recréer une partition logique en ntfs sur l'espace libéré précédemment.

c). Si le disque "téléchargements" est reconnu, j'ai fini. Sinon, je redémarre sous Windows, je copie le contenu sur un disque externe, je formate, et si le disque est enfin identifié, je remets les données dessus. Voilà.
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
14 mai 2014 à 06:59
OK je fait ça ! Je vous donerai des nouvelles cet après midi !
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46 > jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014
14 mai 2014 à 07:07
Pour que ce soit plus simple, je peux utiliser easy BCD sous windows(quant il remarchera) pour refaire le boot d'ubuntu ?
0
Essaie d'agir de manière pondérée... A chaque étape, tu fais le point avant de tout enchaîner... Et tu vérifies aussi que je n'ai pas fait d'erreur sur le numéro de partition (j"ai tout tapé à la suite, donc une erreur est possible, et ça pourrait avoir "quelques conséquences" surtout lors de la commande delete partition - à noter que tu peux aussi, et c'est peut-être plus sûr, supprimer cette partition raw (point D. a) depuis ton Linux, avec gparted).

Tu peux même commencer par un simple
sudo update-grub
depuis ton linux. Si bootmgr est sur le premier disque et qu'il est opérationnel, les points A et B seront carrément inutiles (moi, j'ai envisagé que bootmgr était sur le second disque, ce dont je doute de plus en plus).

Easybcd ne peut gérer grub que si tu as mis le grub sur la partition Linux et non dans le mbr (qui est le choix par défaut de l'installateur). Tout dépend comment ton système démarrait précédemment. Utilisait-il grub ou le lanceur windows? Toi seul peux répondre.
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
14 mai 2014 à 12:02
J'utilise le bootloader Windows et si je veux démarrer ubuntu je le sélectionne dans le bootloader Windows et il m'affiche le bootloader ubuntu ...
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46 > jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014
14 mai 2014 à 13:55
Le dual boot windows\ubuntu refonctionne grâce a votre aide !
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
14 mai 2014 à 20:35
Ubuntu et mes Windows refonctionnent tous, c'est plus clair au niveau des partitions mais le disque dur ide interne n'est toujours pas reconnu par ubuntu !
0
Bon, maintenant, tu vas me dire comment sont branchés tes deux disques durs (lequel est en master, lequel est en slave, et puis sur quel nappe et avec quelle lecteur cd)....
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
Modifié par jujulechti le 14/05/2014 à 21:34
J'ai un disque dur interne en SATA qui contient les o.s. , un lecteur/graveur DVD en SATA lui aussi , j'ai le fameux disque dur interne non reconnu par ubuntu qui est branché seul via une nappe ide avec deux prises (une nappe qui permet le branchement de deux disques durs ide ). Le disque dur SATA est en master et l'IDE en slave . Le lecteur /graveur et le disque dur SATA sont branchés via deux câbles SATA différents et je n'utilise pas d'adaptateur, tout est directement branché à la carte mère .
0
Les disques sata n'ont pas de master ou de slave... je ne comprends pas.... Ton disque ide n'a pas de raison d'être en slave. Mais bon, s'il est seul sur une nappe, ça ne doit pas avoir d'influence, je pense. Essaie tout de même de le passer en master, sait-on jamais. Sinon , ma piste s'écroule.

Le mieux serait de faire une copie des données (par sécurité) et ensuite, on pourrait essayer de voir avec testdisk, tant sous Windows que sous Linux, pour voir si quelque chose de particulier apparaît.
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
Modifié par jujulechti le 15/05/2014 à 18:33
c'est bon j'ai sauvegardé mon disque ! je fais quoi en suite ?
0
Utilisateur anonyme
15 mai 2014 à 20:05
As-tu essayé de le passer en master ?
0
jujulechti Messages postés 96 Date d'inscription vendredi 16 novembre 2012 Statut Membre Dernière intervention 1 septembre 2014 46
Modifié par jujulechti le 16/05/2014 à 15:34
MON DISQUE INTERNE DUR IDE EST RECONNU SOUS UBUNTU !!!!!!
Au lieu de le passer en master via le BIOS, je l'ai sorti de mon P.C. pour déplacé le petit cavalier a coté du port pour la nappe IDE ,avant il était sur les pins de la fonction "select cable", et maintenant il est sur les pins correspondants a la fonction "MASTER", il fonctionne parfaitement bien sous Windows et Ubuntu !

Problème résolu ! Merci de votre aide !
0
Ah, je suis content, car je ne voyais vraiment pas ce que ça pouvait être d'autre. Tu as du coup un disque secondaire qui tourne, et un disque principal remis d'aplomb, ce que tu n'avais sûrement pas envisagé.

(Et tu avais mal compris mon idée... il s'agissait bel et bien de déplacer le cavalier... il n'est pas question de master ou slave dans le bios sans cette modification mécanique... à ne pas confondre avec "la priorité dans l'ordre de boot")

J'attends la livraison de la potion :)

Bye.
0