Fonction "afficher le contenu d'une cellule avec critères" [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
jeudi 27 février 2014
Statut
Membre
Dernière intervention
21 juillet 2014
-
Messages postés
19
Date d'inscription
jeudi 27 février 2014
Statut
Membre
Dernière intervention
21 juillet 2014
-
Bonjour,


J'ai 4 colonnes A, B, C et D contenant des données sur plusieurs lignes.
J'ai 3 valeurs fixées a, b et c, se trouvant respectivement dans les colonnes A, B et C.
Lorsque a, b et c se trouvent sur une même ligne (cela ne peut arriver qu'une seule fois), j'aimerais pouvoir afficher dans une autre case la valeur de la colonne D de cette même ligne.

Je précise que mes colonnes contiennent des chiffres ou du texte.

Quelle formule puis-je utiliser pour cela ?

Merci d'avance !

2 réponses

Messages postés
25264
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 septembre 2020
5 452
Bonjour
si effectivement il ne peut y avoir qu'un cas de figure A B C et que D est une valeur numérique:

=SOMMEPROD(A1:A1000=valeurA)*(B1:B1000=valeurB)*(C1:C1000=valeurC)*(D1:D1000))

Note;: le code SOMMEPROD nécessite des champs avec N° de ligne (type A1:A1000, mais pas A:A)

crdlmnt



Errare humanum est, perseverare diabolicum
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60485 internautes nous ont dit merci ce mois-ci

Messages postés
19
Date d'inscription
jeudi 27 février 2014
Statut
Membre
Dernière intervention
21 juillet 2014

Merci beaucoup, en effet ça fonctionne pour les valeurs numériques mais comment faire quand le contenu à afficher est du texte...?

Pour ce cas là, mon problème est plus simple :
J'ai une valeur "e" numérique contenue dans la colonne E. J'aimerais pouvoir afficher le contenu (qui est du texte) de la case de la colonne D qui se trouve sur la même ligne que "e".

Comment faire...?
Messages postés
25264
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 septembre 2020
5 452
re
=INDEX(D:D;EQUIV(e;E:E;0))
e étant bien sur numérique

pour ressortir une valeur de D en ligne avec trois valeurs en W1,Y1,Z1 si D n'est pas numérique

=INDEX(D:D;EQUIV(W1&"_"&Y1&"_"&Z1;A:A&"_"&B:B&"_"&C:C;0))

formule matricielle à entrer avec le touche ENTER en maintenant les touches ctrl et shift enfoncée. Elle se retrouve entre accolades automatiquement dans la barre de formule:

Nota: les "intercalaires "_" ne sont utiles que si les valeurs dans A, B,C sont numériques.


crdlmnt
Messages postés
19
Date d'inscription
jeudi 27 février 2014
Statut
Membre
Dernière intervention
21 juillet 2014

Merci beaucoup, ça fonctionne !
Messages postés
5506
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
2 septembre 2020
479
Bonjour

Si j'ai bien compris votre question

=SI(ET(A1="a";B1="b";C1="c");D1;"")

remplacer "a" , "b" , "c" par les vrai valeurs
si c'est faux la cellule n'affiche rien ""
Messages postés
19
Date d'inscription
jeudi 27 février 2014
Statut
Membre
Dernière intervention
21 juillet 2014

Bonjour,
Merci de votre réponse mais dans mon cas A1, B1 et C1 sont inconnus, c'est justement le problème. Mais Vaucluse a trouvé une solution c'est bon, merci beaucoup !