Supprimer toutes les lignes contenant le mot "aspirateur" [Fermé]

Signaler
Messages postés
1
Date d'inscription
lundi 7 avril 2014
Statut
Membre
Dernière intervention
7 avril 2014
-
Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
-
Bonjour à tous et toutes !

Dans Open Office calc, j'ai un fichier de 1800 lignes. Je souhaite supprimer toutes les lignes contenant le mot "aspirateur". Le mot aspirateur pouvant apparaitre au milieu d'une chaine de caractère type mail, comme par exemple "jean.michel@monbelaspirateur.com"
>> je souhaite supprimer toute la ligne car elle contient le mot "aspirateur".

Je suis totalement novice avec les macros et j'ai testé pas mal de codes trouvés ça et là mais sans résultat (si ce n'est des erreurs :(

Je remercie d'avance celui ou celle qui me donnera la bonne procédure ou le bon code qui marche !

Thx a lot

2 réponses

Messages postés
33
Date d'inscription
jeudi 27 mars 2014
Statut
Membre
Dernière intervention
17 août 2014
3
Bonsoir

tu pourrais utiliser la fonction rechercher (ctrl + F) en cherchant aspirateur et a chaque fois que exel trouve le mot. Tu supprimes la ligne.

C'est peut etre long mais au moins tu seras sur de ne rien oublier
Messages postés
24141
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
6 845
Bonjour,

ou bien :
=SI(ESTERREUR(CHERCHE("aspirateur";A2));"";"à supprimer")
à tirer vers le bas.
Filtrer sur cette colonne sur "à supprimer", sélectionner toutes les lignes pour les supprimer.

eric