Calcul du nbr de A ds un plage de cellule [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
mercredi 19 mars 2014
Statut
Membre
Dernière intervention
20 mai 2014
-
Messages postés
6
Date d'inscription
mercredi 19 mars 2014
Statut
Membre
Dernière intervention
20 mai 2014
-
Bjr, j'essaye la fonction =COUNTIF(S3:S86;"*T*")
Pour calculcer le nbr de T ou A ds une collonne mais le nbr n'est pas correct, je pense que si j'ai une serie de TAT par ex il me compte qu'un seul T au lieu de 2...
exemple
A B C
1 AT
2 T
3 TAT
4 A
Merci pour votre aide

7 réponses

Messages postés
1941
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
23 août 2020
149
Bonjour,

ça gêne si tu cherches le nombre de T ligne par ligne (de la même manière qu'ici : https://forums.commentcamarche.net/forum/affich-26152234-calcul-nb-caracteres-identiques-cellule-excel et que tu fais le total ?

A+
Messages postés
6
Date d'inscription
mercredi 19 mars 2014
Statut
Membre
Dernière intervention
20 mai 2014

Merci Zoul67

Mais le truc c'est que je vais devoir faire la même chose par ligne
Il s'agit d'un fichier qui reprend dse agents ( 1,2,3...) et les dates du mois (A,B,C,...)

et j'avoue j'avais fait des recherches mais ca ne fonctionne pas car l s'agit d'une plage de cellule dans les 2 sens et il met du coup VALEUR...
Messages postés
1941
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
23 août 2020
149
Alors combine la concaténation et le calcul du nombre de caractères identiques.
Messages postés
35
Date d'inscription
dimanche 23 décembre 2007
Statut
Membre
Dernière intervention
28 mai 2019
9
Bonjour,
=COUNTIF(S3:S86;"T") devrait fonctionner.
*T* indique qu'il doit prendre en compte n'importe quel T entouré de n'importe quel caractère et en n'importe quelle quantité donc TAT compte pour 1 (un T précédé d'un espace blanc et suivi de 2 lettres).
Messages postés
6
Date d'inscription
mercredi 19 mars 2014
Statut
Membre
Dernière intervention
20 mai 2014

Mais il devrais m'en compter 2....
Messages postés
2477
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
18 juin 2021
973
Bonjour,
Peut-être en faisant une somme matricielle avec la proposition de zoul67:
=SOMME(NBCAR(A1:A11)-NBCAR(SUBSTITUE(A1:A11;"T";"")))
à valider avec la combinaison de touches ctrl+shift+enter.
Messages postés
6
Date d'inscription
mercredi 19 mars 2014
Statut
Membre
Dernière intervention
20 mai 2014

Je vais essayer en anglais si je ne me trompe pas c'est alors =SUM(LEN... ?
Messages postés
6
Date d'inscription
mercredi 19 mars 2014
Statut
Membre
Dernière intervention
20 mai 2014

Oui ca m'a l'air d'être tout bon!!!!
C'est le truc de la validation que je ne connaissais pas!!

Un tout gd merciiiiiii
Youhou