Trouver la bonne formule SI

Résolu/Fermé
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
- 9 mars 2014 à 17:40
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
- 10 mars 2014 à 12:07
Bonjour

J'ai besoin de votre aide. Je cherche les formules pour le tableau ci-dessous:

Quantité Nombre de dossiers
1er A
2nd B
du 03ème au 09ème C
du 10ème au 14ème D
A partir du 15ème pack E

Ce que je voudrais pour la colonne nombre de dossiers :
Si A=1 alors nombre de dossiers = 5 sinon erreur
Pareil pour B
Si C> 7 alors erreur sinon nombre de dossiers = C * 5
Si D> 5 alors erreur sinon nombre de dossiers = D * 5

Je vous remercie beaucoup de votre aide,

5 réponses

Raymond PENTIER
Messages postés
56468
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 août 2022
17 193
9 mars 2014 à 19:54
marij55, relis-toi : tu verras que c'est incompréhensible et inexploitable.
Aziz a été bien sympa, mais il a joué au loto ...
Reprends ton explication de manière claire (quelle colonne correspond à quelle donnée ?) ; ou mieux, fais comme tout le monde en envoyant ton fichier avec https://www.cjoint.com/
1
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
26
9 mars 2014 à 20:43
Il a joué...et il a gagné ;-)

Je marque le post en Résolu.

Merci et bonne soirée,
0
JvDo
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
850
10 mars 2014 à 00:31
Bonsoir,

Je suis comme Raymond Pentier, je n'ai rien compris à ta demande, mais pour rendre ta formule acceptable, tu pourrais essayer :
=SI(B6=0;"0";SI(B6=1;"5";"erreur")) 
cdlt

PS : as-tu vraiment besoin de mettre tes chiffres 0 et 5 en caractères plutôt qu'en nombres?
1
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
26
Modifié par marij55 le 10/03/2014 à 07:13
Merci.
J'ai une petite question, dans la formule quelle est la différence entre caractères et nombre?
Sinon, c'est tout bon! Merci beaucoup, ma journée commence bien!
0
JvDo
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
850
10 mars 2014 à 11:29
tu peux avoir des surprises lors de l'utilisation de formules.

Exemple : si tu mets "5" en A1 et 5 en A2 (donc un caractère puis un chiffre) et si tu écris en A3 la formule =somme(A1:A2), tu obtiendras 5 (valeur numérique) au lieu de 10.

si tu écris une autre formule du genre =SOMMEPROD(1*(A1:A2=5)), puis =SOMMEPROD(1*(A1:A2=5)), même souci : 1 à chaque fois alors que tu pourrais escompter obtenir 2 puisque visuellement, tu vois deux cinq.

En revanche d'autres formules font la conversion de type. NB.SI(A1.A2;5) ou NB.SI(A1:A2;"5") ou encore A1+A2 fonctionnent "correctement".

Au niveau format de cellule, en standard les chaînes de caractères sont cadrés à gauche et les nombres à droite.

Tu peux forcer la conversion de type en ajoutant des opérateurs comme -- ou 1* devant les cellules concernées. Si tu mets =SOMME(--A1:A2) et que tu valides par CTRL+MAJ+ENTER, tu obtiendras 10.

conclusion :attention au mélange de types.


cdlt
0
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
26
10 mars 2014 à 12:07
Merci beaucoup pour ces précieuses informations.

Bonne journée,
0
aziz_alg80
Messages postés
378
Date d'inscription
vendredi 12 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
22
9 mars 2014 à 18:07
* =si(A2=1;5;"erreur")
* =si(B2=1;5;"erreur")

* =si(C2>7;"erreur";C2*5)
* =si(D2>5;"erreur";D2*5)

peut être qu'il y a des erreurs sur les arguments de la fonctions parce que j'ai pas bien compris!
0
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
26
9 mars 2014 à 20:42
Merci. C'est tout bon! Bonne soirée Aziz
0
Raymond PENTIER
Messages postés
56468
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
9 août 2022
17 193
9 mars 2014 à 20:47
Tant mieux ; la Chance est avec toi ...
Mais pour ta 49ème question, essaie d'être plus explicite.
0
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
26
9 mars 2014 à 21:00
Je vais essayer, mais dés fois, c'est dur :-)
0
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
26
9 mars 2014 à 21:54
Voilà la 49ème, je vais essayer d'être plus claire :-)

Soit X le nombre de pack en cellule B6
Soit Y le nombre de dossiers en cellule C6
1 pack contient 05 dossiers.

Je voudrais dans la même case mettre 03 conditions :
Si B6=0 alors C6=0
Si B6=1 alors C6=5
Si B6>1 alors C6=erreur

Quelle est la formule à mettre en C6?
J'arrive à mettre les deux premières conditions, mais pas la troisième.

Merci beaucoup,
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
marij55
Messages postés
138
Date d'inscription
mardi 31 juillet 2012
Statut
Membre
Dernière intervention
4 décembre 2014
26
9 mars 2014 à 22:10
Pour mettre 03 conditions sur la même formule, j'ai fait :

=SI(SI(B6=0;"0");SI(B6=1;"5");SI(B6>1;"erreur"))

Pour B6>1 c'est bon, mais pour les 2 premières conditions, ca ne marche pas.

Merci de votre aide!
0