Comment faire une sommes multi critere sur 1 colonne [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
jeudi 20 février 2014
Statut
Membre
Dernière intervention
20 février 2014
-
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
-
Bonjour

Je débute sur Excel et je rencontre le problème suivant : j'ai 2 colonnes la 1er du texte avec des noms de pays, la deuxième uniquement des chiffres.Je souhaiterai additionner le chiffre d'affaire de 3 pays
J'ai essayé avec la fonction somme si elle marche très bien lorsqu'il y a un seul pays en critère pour mettre plusieurs pays j'ai essayé d'utiliser la syntaxe suivante ou("France"; "Allemagne" ; "Japon") cela ne fonctionne pas ??
j'ai aussi essayé la fonction somme si ens. mais si elle fonctionne avec plusieurs critères il faut que chaque critère soit dans une colonne différente ce qui n'est pas mon cas.

Merci d'avnce pour votre aide

4 réponses

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 735
Bonsoir
pourquoi ne pas simplement faire:
=SOMME.SI(champ pays;pay;champ montant)+SOMME.SI(champ pays; ect...

sinon vous pouvez aussi écrire si votre champ est:
pays de A1 à A100 et montant de B1 à B100
=SOMMEPROD(((A1:A100="France")+(A1:A100="japon")+(A1:A100="Allemagne))*(B1:B100))
Attention aux parenthèses
crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
3
Date d'inscription
jeudi 20 février 2014
Statut
Membre
Dernière intervention
20 février 2014

Bonsoir

Merci pour votre aide je trouve cela géniale car c'est la 1er fois que je fais appel a ce site et c'est très agréable de se sentir soutenu :=)

Votre 1er solution marche parfaitement

Pour la deuxième voilà ce que j'ai mis =somme.prod(((A1:A5="France")+(A1:A5="Allemagne")*B1:B5)) et le résultat est un message d'erreur "NOM?" Pour info j'ai Excel 2007 et lors j'essaye de taper somme.prod dans la liste des fonctions celle ci n'apparaît pas, ceci explique peut être cela?

Mon idée d'utiliser la syntaxe "ou" dans le critère de la fonction somme si n'est donc pas possible ? En fait je voudrais juste valider le fait qu'il n'est pas possible d'utiliser les "ET" OU" dans les fonctions

merci
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 735
On explique simplement parce qu'il n'y a pas de point entre SOMME et PROD > SOMMEPROD
Par ailleurs, il manque quelques parenthèses
=SOMMEPROD(((A1:A5="France")+(A1:A5="Allemagne"))*(B1:B5))
crdlmnt
Messages postés
3
Date d'inscription
jeudi 20 février 2014
Statut
Membre
Dernière intervention
20 février 2014

super les 2 fonctionnent et merci encore
bonne soirée
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 735
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt