Recherche caractère * dans cellule

[Résolu/Fermé]
Signaler
Messages postés
101
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
23 mars 2016
-
Messages postés
101
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
23 mars 2016
-
Bonjour,

j'utilise actuellement la formule =SI(ESTNUM(CHERCHE("!";D2));"oui";"non") pour rechercher le caractère "!".

Mon objectif, toutefois est de rechercher le caractère "*".
Malheureusement, ce dernier a une signification spécifique pour excel, et quand je le recherche via ma formule, les résultat est toujours OUI.

Comment contourner cet obstacle ?

Merci d'avance.
A voir également:

3 réponses

Messages postés
1017
Date d'inscription
mardi 23 décembre 2008
Statut
Membre
Dernière intervention
10 janvier 2018
303
Bonjour,

Essayez ça :
=SI(ESTNUM(CHERCHE("~*";D2));"oui";"non")
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
101
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
23 mars 2016
3
Merci beaucoup. ça marche à merveille.
Juste par curiosité:
Quelle est la signification du caractère ~ pour Excel ?
Messages postés
1017
Date d'inscription
mardi 23 décembre 2008
Statut
Membre
Dernière intervention
10 janvier 2018
303
Aucune idée, j'ai trouvé la solution sur internet sur les forum anglais ^^.
Le principal, c'est que ça fonctionne :)
Messages postés
101
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
23 mars 2016
3
ok merci
Messages postés
24196
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
10 octobre 2021
6 923
Bonjour,

Juste par curiosité:
Quelle est la signification du caractère ~ pour Excel ?

* étant un caractère générique pour excel comme tu l'as remarqué (* veut dire n'importe quelle chaine de caractère) , le ~ force excel à interpréter le caractère suivant comme un caractère 'normal'.

eric
Messages postés
101
Date d'inscription
lundi 15 octobre 2012
Statut
Membre
Dernière intervention
23 mars 2016
3
merci de l'info !