Problème au démarrage de Linux [Résolu/Fermé]

Signaler
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
-
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
-
Bonjour à tous!
J'ai voulu installer Linux Mint 16 sur un de mes disques-dur.
Pour ça, j'ai téléchargé l'ISO par fichier torrent ici et j'ai créé un LiveUSB avec Linux Live USB Creator. Jusque-là pas de soucis.
Je démarre donc sur ma clef, la session live fonctionne parfaitement. J'installe donc l'OS sur mon disque-dur sensiblement de la même manière que j'avais faite pour Ubuntu il y a quelques mois (et qui avait bien marché):
Partition 1: OS, 8192Mo, Ext4, monté sur /
Partition 2: Données, 18000Mo, Ext4, monté sur /home
Partition 3: SWAP, 2048Mo
(J'ai installé sur la première partition si vous ne l'avez pas compris.)

Une fois l'installation terminée, je clique sur le bouton "Redémarrer maintenant" ("narmol" me direz-vous).
J'appuies sur la touche F2 pour ouvrir UEFI (mon menu de boot) et fais démarrer mon PC sur le disque-dur ou je viens d'installer Linux.

Ma là, il y a un gros problème: J'ai le droit qu'a quelques apparitions de "-" furtifs, avant que j'ai un message d'erreur de démarrage Windows (du style: Votre PC n'a pas pu démarrer correctement, choisissez une option de démarrage ..."). Pourtant, Linux est bien installé sur ce disque-dur. Mais il semble que le démarrage ne se fait pas, et que mon pc décide alors de passer à Windows. Ou est passé l'habituel GRUB? Pourquoi Linux ne démarre pas?
Je ne sais pas, et Google non-plus apparemment. J'ai essayer de ré-installer deux fois et refaisant les partitions et en changeant le média d'installation, mais sans succès.


Merci de toute aide.

"Entre la guerre et le déshonneur, vous avez choisi le déshonneur. Eh bien vous aurez la guerre!"
Dixit Winston Churchill, s'adressant à la France et à l'Angleterre.

3 réponses

Bjr

La réponse est contenue dans ta question. Tu tentes d'installer ton Mint sur un PC réglé en mode uefi et tu ne crées pas de partition efi. Ça ne se lancera jamais si tu démarres le DD dans ce mode uefi.

Il faut savoir comment tout ça est mis en place (les réglages du bios et le format du disque dur). Si le disque dur est au format mbr, ton Mint devrait se lancer si tu passes le bios en legacy ou si tu actives l'option "csm" et que tu bootes en mode "classique".

Je te conseille de lire ceci:

http://doc.ubuntu-fr.org/uefi

Après, tu choisis: le mieux est de faire les choses proprement. Soit uefi, soit legacy.

- Soit tu installes en uefi, et donc le disque dur sera au format gpt et il faudra une partition efi de moins de 300 Mo au début (je pense que Mint 16 utilise le même protocole qu'Ubuntu)

- Soit tu passes le disque dur en mbr, et alors il faut passer le bios en legacy et tu installes comme autrefois.
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
1 040
Merci, je vais essayer d'installer en UEFI.
Au passage, je voudrais installer Linux Mint aussi sur une clef usb 3.0 de 32Go que je pourrais utiliser partout. Est-ce que le fait d'installer là aussi en UEFI fera que je ne pourrais pas l'utiliser n'importe-ou?
Utilisateur anonyme
Aucune idée... je n'ai jamais tenté d'installation uefi sur usb.
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
1 040
Bon bah je verrais bien si ça marche ou pas...
...
....
.....
......
.......
........
Purée que c'est long d'installer sur une clef usb! (même en 3.0! ^^')


Mais je suppose que ça devrait passer, puisque pour une installation pour un démarrage "legacy", il n'y a rien de spécial à faire.
Utilisateur anonyme
Non, en legacy, c'est comme avec un bios traditionnel.
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
1 040
Donc, j'ai recommencé l'installation, cette fois-ci avec une partition EFI (j'ai essaye Fat32 puis "EFI").
Linux est alors dispo en UEFI et en Legacy lors du boot, Respectivement sous les noms "Ubuntu" et "SamsungST1(...)".
Mais Mint UEFI ne se charge toujours pas au démarrage et laisse la place à Windows. Quand au mode Legacy, le pc indique que je ne suis pas sur un périphérique bootable.


J'ai quelques questions:
1) a/ Est-ce que en utilisant un autre logiciel pour créer la liveUSB, ça pourrait marcher?
b/ J'ai entendu parlé de "unetbootin" (ou quelque-chose du genre), est-ce un bon softwware?
2) Pourquoi Ubuntu (qui était sur ce disque-dur avant que j'installe Mint) n'a pas eu besoin de partition EFI pour fonctionner sur ce pc?


"Entre la guerre et le déshonneur, vous avez choisi le déshonneur. Eh bien vous aurez la guerre!"
Dixit Winston Churchill, s'adressant à la France et à l'Angleterre.
1. Tu peux essayer mais je ne pense pas que ça change quelque chose.
2. Tout dépend comment tu l'a installé... difficile de dire sans avoir vu les partitions.

Quoi qu'il en soit

A. Vérifie avec le live cd que la partition efi a bien le drapeau boot. Si oui, jette un oeil à son contenu pour voir si le dossier efi/boot existe et si le fichier bootx64.efi est présent. Vois aussi si Mint a créé un dossier contenant grub.efi.

Ensuite, tente une réparation avec boot-repair (la version sur linux secure est compatible uefi). Tu verras bien ce qu'il se passe (mais j'avoue que le processus d'installation de Mint en uefi m'est inconnu).

B. Quant au nom "samsung st1", il est bizarre. N'as-tu pas un autre disque dur là-dedans ? Ou alors est-ce un disque dur hybride qui contiendrait une ssd caché!

C. Enfin, quand tu passe en legacy, il est normal que ça ne boote pas puisque le pc attend un disque au format mbr. Il faut redémarrer avec le live-cd en mode legacy, refaire la table de partitions avec gparted en choisissant "ms-dos", et réinstaller Mint en mode traditionnel. Et là, en principe, ça doit fonctionner.
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
1 040
Effectivement, refaire ma LiveUSB n'a rien changé.

A/ Vérifié, tout est ok.
J'ai essayé le Boot Repair. Mais j'ai un message disant qu'il faut d'abord désactiver le démarrage sécurisé. Mais j'ai un petit pb d'option non-modifiable... (cf image). J'ai pas trouvé comment changer ça.

B/ En fait je me suis un peu trompé sur les noms, donc les voici en image.

C/ J'ai pas top compris l'histoire de table en ms-dos (nouveau linuxien je suis). Il faut refaire les partitions, en ms-dos? Je ne l'ai pas vu une-seule fois ms-dos donc je suppose que j'ai mal compris...
Donc, il faut désactiver le "secure boot"... Essaie ce qui est proposé ici

https://forums.commentcamarche.net/forum/affich-29606691-impossible-de-desactiver-le-secure-boot-dans-l-uefi#18

ou ici

http://doc.ubuntu-fr.org/desactiver_secure_boot

On verra la question de la table ms-dos si tu n'y parviens pas.

Il sort d'où, ce Windows 7 ? Tu as combien de disques durs ?
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
1 040
Ca marche!!! Youpi!!!

Grand merci à toi ikewdu!

Ce que j'ai fait:
Dans le menu UEFI, je suis allé dans
Démarrage/Secure Boot Menu/Clés de Gestion/Supprimer (...)
. Ainsi, le Secure Boot c'est désactivé. J'ai également mis le type d'OS en
Another OS
. Et voilà! J'ai pu démarrer sans pb!

PS: oui, j'aurais du être un peu plus précis au sujet du "un de mes disques-dur". En fait, j'en ai deux. Un pour Windows et un pour Linux.
Eh bien, tout est bien qui finit bien. Mets en résolu.
Messages postés
5965
Date d'inscription
dimanche 10 février 2013
Statut
Membre
Dernière intervention
18 mars 2018
1 040
Yep. Merci! :D