Trouver une date dans une période dans un fonction recherche V

Fermé
laurep Messages postés 3 Date d'inscription mercredi 3 avril 2013 Statut Membre Dernière intervention 11 février 2014 - 10 févr. 2014 à 19:23
Mike-31 Messages postés 18174 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 janvier 2023 - 11 févr. 2014 à 08:58
Bonjour,
comment trouver une date dans une période et cela inséré dans une fonction recherche V.
Je vous transmet mon fichier, en feuil 1 la base de donnée en feuil2 ma recherche.
Merci de votre aide

https://www.cjoint.com/?3Bktv6q16ds



A voir également:

6 réponses

Raymond PENTIER Messages postés 56979 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 26 janvier 2023 17 175
10 févr. 2014 à 21:17
Bonjour.

Peut-on savoir où tu as trouvé une formule aussi fantaisiste ?
La formule =RECHERCHEV(A1&B1&C1;$A$1:$E$18;5;FAUX) saisie en Feuil2!D1 signifie très exactement :

Prendre comme référence "Força Réal4158741628" et rechercher dans la plage de cellules Feuil2!$A$1:$E$18 ce qu'il y a dans la cinquième colonne (E) à la ligne contenant "Força Réal4158741628" en première colonne, même si la colonne A n'est pas triée !

Avec ça tu ne peux pas aller très loin ...
0
Raymond PENTIER Messages postés 56979 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 26 janvier 2023 17 175
10 févr. 2014 à 21:32
En effet, en Feuil2, la donnée stockée par Excel en B1 est le nombre 41587. Celui-ci, affiché au format Date, apparaîtra comme 9 novembre 2013. De même en C1 la date du 20/11/13 est enregistrée comme étant la donnée 41628 (nombre de jours écoulés depuis le 1er janvier 1900, date de début du calendrier Excel).

En Feuil1 la clé de la colonne A ressemble à "Força Réal4158741628" mais avec une seule date concaténée, comme Força Réal40125 en A2, qui serait la concaténation de "Força Réal" et de 08/11/09.

Donc ta référence "Força Réal4158741628" n'existe dans aucun tableau et ta recherche affichera toujours #N/A ...
0
Raymond PENTIER Messages postés 56979 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 26 janvier 2023 17 175
Modifié par Raymond PENTIER le 10/02/2014 à 21:39
D'autre part je suppose (puisque tu n'as pas fourni d'explication claire) que le but de ta formule est de trouver le tarif correspondant à ta référence, c'est-à-dire à la colonne E (N° 5) de la Feuil1 ? Tu as oublié de le préciser, en écrivant
=RECHERCHEV(A1&B1&C1;$A$1:$E$18;5;FAUX) au lieu de
=RECHERCHEV(A1&B1&C1;Feuil1!$A$1:$E$18;5;FAUX) ...

Suite à toutes ces remarques, pourrais-tu rédiger de manière plus complète ta question ? Et en particulier, nous détailler ce que tu voulais dire par "trouver une date dans une période" !

C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
0
Mike-31 Messages postés 18174 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 janvier 2023 5 029
10 févr. 2014 à 21:46
Bonsoir,

Lorsqu'on copie une formule, il faut considérer l'ensemble des données.

pour que ce type de formule fonctionne il faut Feuil1, créer une colonne en A et coller cette formule en A2 =C2&D2&E2 et l'incrémenter vers le bas, cette colonne peut être masquée. Pour simplifier la formule nomme la plage A1:F18 exemple nommée List

Feuil2 en D1 cette formule
=RECHERCHEV(A1&B1&C1;List;6;0)

Il faudrait compléter la formule avec une gestion d'erreur pour éviter #N/A comme par exemple
=SI(ESTNA(RECHERCHEV(A1&B1&C1;List;6;0));1;2)

dans les deux cas incrémenter la formule vers le bas
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
laurep Messages postés 3 Date d'inscription mercredi 3 avril 2013 Statut Membre Dernière intervention 11 février 2014
11 févr. 2014 à 07:10
Bonjour,

je souhaite dans la feuill2 dans la colonne tarif avoir
le tarif en fonction du nom, de la date début et de la date de fin.
La base de donnée est la feuille 1.
Merci



https://www.cjoint.com/?3BlhdI8duEk
0
Mike-31 Messages postés 18174 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 janvier 2023 5 029
11 févr. 2014 à 08:58
Re,

regarde ton fichier

https://www.cjoint.com/?DBli5NwzqfM
0