Montage lecteur réseau avec %USERNAME%. [Résolu/Fermé]

Signaler
-
Messages postés
3011
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
12 novembre 2020
-
Bonjour,
J'ai un doute sur l'utilisation de la variable evironnement %USENAME%.

J'ai créé un partage sur mon serveur de fichier w2008r2 avec l'accès controle total pour mon utilisateur "toto".
Grace à une gpo et un script d'ouverture de session, je lance le montage de plusieurs lecteurs réseau.
Hors il y a un seul lecteur réseau qui n'est pas créé, c'est le suivant:
net use Y: \\serveurfic\users\%USERNAME% 

Quand j'essai de monter manuellement le lecteur sur la machine de l'utilisateur cela ne fonctionne toujours pas. Message: "La ressource ou le périphérique réseau spécifié n'est plus disponible"

Pourtant, avec la commande:
net use Y:  \\serveurfic\users\toto 
le montage du lecteur reseau se fait correctement.

D'où ma question: Peut-on utiliser la variable d'environnement %USERNAME% dans un chemin réseau pour le montage d'un lecteur réseau?

2 réponses

Messages postés
3011
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
12 novembre 2020
400
Bonjour,


Peut-on utiliser la variable d'environnement %USERNAME% dans un chemin réseau pour le montage d'un lecteur réseau?
Oui.



Le problème vient peut-être d'ailleurs.


- le réseau n'a pas bien fini de "monter", et le script se lance. (il faut vérifier un paramètre de GPO : "attendre le réseau blablabla...."

- le login script doit être lancé pour des utilisateurs et non des machines (comprendre "contexte utilisateur" et non contexte "machine" : la GPO est-elle liée à une OU comprenant des utilisateurs ou des machines ?). Ce point est une très bonne piste.

- Est ce que la lettre Y: est bien disponible au moment où le script s'exécute. (càd que la lettre n'est pas utilisée pour un autre device. Au pire changer la lettre pour tests...)

- Eviter les noms courts "netbios" lorsque l'on pointe sur un serveur, surtout dans des scripts. Utiliser le FQDN est conseillé : tant au niveau résolution, on force DNS dans ce cas, et non netbios (WINS/Broadcast/Hosts etc ...) ; tant au niveau migration future : si le nom du serveur change, il suffit de garder cet alias pointant sur le nouveau serveur ... donc pas besoin de modifier le script.

- Les lecteurs mappés doivent être démontés à la fermeture de session.
Au mieux utiliser
net use * /delete /yes
en début de script.
Ou également l'option
/persistent:no
pour chaque lecteur au montage.

- Faire des redirections dans des logs pour les retours d'erreurs est une bonne façon pour trouver l'origine du problème.

-

Dernier point, utiliser des scripts pour lancer le montage de lecteurs mappés, c'est devenu disons, "OldSchool".
On utilise maintenant les GPP pour monter les lecteurs réseaux ('surtout' avec du 2008R2 ...)

On peut donc avoir qu'une seule stratégie de groupe, mais avec plusieurs GPPs dedans, qui pointent sur différents lots d'utilisateurs et de groupes....

On peut alors monter des lecteurs mappés pour différents groupes d'utilisateurs (genre 'Compta' d'un coté et 'Direction' de l'autre) au sein d'une seule et même stratégie ; c'est à dire qu'on filtre l'appartenance des groupes dans les GPPs...

Fais des tests avec les GPPs, c'est relativement puissant ; il y a des possibilités de filtres assez fun.

Messages postés
3011
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
12 novembre 2020
400