Nombre de "cases" correspondant à deux criteres Excel [Résolu/Fermé]

Signaler
-
Messages postés
12186
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
15 octobre 2020
-
Bonjour a tous,

Une petite question sur excel:
Alors j'ai deux colones: - la premiere dans laquelle j'ai les dates d'ouverture des dossiers
-la deuxieme avec soit les date de renouvellement du dossier ( soit rien si le dossier n'est pas renouvellé)

Je voudrais mesurer dans une cellule par exemple le nombre de dossier ouvert avant le 1er janvier 2011 ( donc en 2010) et qui presente un renouvellement.(En sachant que le renouvellement n'est pas toujours present le dossier peut ne pas etre renouveller, d'ou des vides dans la deuxieme colonne)

Par exemple:

ouverture renouvellement
01/02/2010 01/03/2011
04/01/2010
02/05/2010 03/06/2011
03/03/2011 04/04/2012
04/05/2012
01/09/2010 02/10/2011
03/03/2011

Donc ici avec le critere ouvert en 2010 et renouvellement je devrais avoir : 3

J'ai essayer avec nb et sommeprod mais je n'y arrive pas ... quelqu'un saurait comment faire ?

En vous remerciant par avance



2 réponses

Messages postés
12186
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
15 octobre 2020
2 512
Bonjour,

Il faut combiner SOMMEPROD et DATEVAL. DATEVAL va convertir une date donnée sous format de texte en date et donc permettre la comparaison avec les dates que vous avez colonne A.

La formule est donc :
=SOMMEPROD((A2:A803<DATEVAL("01/01/2011"))*(B2:B803<>""))

Attention dans une Sommeprod, les matrices doivent être de mêmes longueurs... (A2:A803 = B2:B803 en nb de lignes...)
Youhou ! Merci impect sa fonctionne.
Un grand merci.
Messages postés
12186
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
15 octobre 2020
2 512
Mais de rien, You're welcome
A+