Aide sur formule excel 2007 [Résolu/Fermé]

Signaler
-
 farfadet9 -
Bonjour,

Je ne réussis pas à faire fonctionner entièrement une formule. Il doit y avoir une erreur, mais je ne la trouve pas.

Les données sont les suivantes :

A1 = Nb de mois (8)
B1 = Nb de jours (22)
C1= NB mois arrondis --> Résultat attendu de la formule soit 9 si supérieur ou égal à 15 ou reste à 8 si inférieur à 15)

=SI(B1>=15;A1+1;0)
Cette formule fonctionne très bien avec l'ajout de 1, mais ne fonctionne pas du tout si B1 est inférieur à 15

Peut-être à noter : les colonnes A et B sont les résultats d'une concaténisation.

Quelqu'un peut-il m'aider ?
Merci.

6 réponses

Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
551
Bonjour

=SI(B1>=15;A1+1;A1)
Cela ne fonctionne pas non plus.

Ce qui m'étonne c'est que cela soit au bureau ou sur mon PC à la maison rien à faire.

Peut-il s'agir d'un problème excel 7?

Merci en tout cas pour cette rapide réponse.
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
551
Bonjour

Si A et B sont le résultat d'une concaténation il faut utiliser CNUM(B1) pour passer leur valeur en nombre car actuellement cela doit être du texte
Bonjour,

Exactement ! Nous avons trouvé hier au bureau. C'est tout à fait du au fait que les nombres sont en texte. Bravo PHILOU10120 !

Il me reste une question : pourquoi la moitié de la formule fonctionne et pas l'autre ? Enfin j'accepte de ne pas comprendre ce point, le principal étant que la formule fonctionne très bien.

Merci beaucoup.
Bonne journée
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
551
Qu'entendez-vous par la moitié de ma formule? ça marche ou ça marche pas autrement il y a un problème.
Non non ça marche très bien. Ce que je voulais dire : pourquoi (donc avant de trouver la solution texte/num) la formule fonctionnait pour le +1 mais pas pour la suite ? puisque le "test" de la formule porte sur la même cellule ou le chiffre est "formaté" en texte [=SI(B1>=15;A1+1;A1)].
Merci.
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
551
Non le teste ne marchait pas =si ( teste; vrai ; faux) et la réponse était toujours A1 faux, le teste n'étant jamais vrai vous n'aviez jamais A1+1
Justement c'était uniquement le +1 qui fonctionnait

A B C
11 29 12 résultat C exact
6 13 7 résultat C faux
8 16 9 résultat C exact
6 9 7 résultat C faux

Mais ce n'est pas grave.
Merci.