Je n'arrive pas a faire une formule pour les congés payés [Résolu/Fermé]

Signaler
-
Messages postés
669
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2020
-
Bonjour,

Je suis en train de faire un tableau excel pour calculer les congés payés de tous les salariés.

Dans la même ligne (correspondant à 1 salarié) je veux écrire "c" ou "R"...
C congé payé
R RTT
CSS Congé sans solde
Cette formule marche très bien =NB.SI(B22:AH22;"C") mais ma problématique est la suivante : on peut prendre des demi-journées (soit 0.5) et des journées.

Comment faire ? J'espère avoir été claire.

Merci d'avance pour votre aide.

9 réponses

Messages postés
669
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2020
55
Bonjour,

A toi de distingué la période de R de C de CSS etc ... savoir si c'est 1 ou 0,5

Cdt,
c'est à dire ?
Messages postés
669
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2020
55
Faut que tu rajoute une colonne dans ton tableau a côté de la raison de l'absence, la durée en jours,
Et oui je comprends mais c'est ce que je voulais éviter.

J'espérais qu'il y avait une formule qui pouvait distinguer les valeurs des critères.
En plus, je suis certaine qu'il y a une astuce, mais encore faut-il la trouver.

critère de la cellule B24 "c"= valeur 1
critère de la cellule B27 "e"= valeur 0.5

Il faudrait une formule qui distingue qui si "c" alors 1 et si "e" alors 0.5 et faire la somme de tous les "c" et "e".

Merci quand même pour ton aide
Messages postés
669
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2020
55
Envoi le fichier via www.cjoint.com

On travaillera directement dessus ça sera plus facile,

Cdt,
http://cjoint.com/data3/3JDmMcKfmp4.htm
Messages postés
669
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2020
55
=NB.SI(B7:AH7;"C")+(NB.SI(B7:AH7;"E")/2)

En imaginant que E = 1/2 de C soit 0,5 jour d'un CP
Merci mille fois. Je viens de faire l'essai et ça marche. C'est exactement ce que je voulais.

Très bonne journée et encore merci
Messages postés
669
Date d'inscription
mardi 27 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2020
55
De rien,

Pense à passer en résolu,

Cdt,