Calcul de nombre de cellules en fonction d'un resultat [Résolu/Fermé]

Signaler
-
 pepegentil -
Bonjour,



excel 2003.

Bonjour .

J vais essayer d'être bref et concis ...

Dans un tableau excel comprenant 31 lignes et 14 colonnes se rapportant à des relevés sanguins , j'aimerai pouvoir faire le total des hypos des hipers et des normales en sachant que l'hypo est en dessous de 0,7 l'hyper au dessus de 1,7 et le normal entre 0,7 et 1,7.

Toutes les cellules ne sont pas systématiquement remplies et j'ai mis un fond jaune pour le résultat sous 0,7 , un fond rouge pour le résultat supérieur à 1,7 ...

La question est donc de me donner le nombre d'hypos , d'hypers et de normals dans le mois ...

J'espère avoir été clair

Merci de votre aide

4 réponses

Messages postés
9677
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 février 2021
2 044
Bonjour

Un exemple
https://www.cjoint.com/?CIupLgE26iZ

bonne suite
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 506
Bonjour,

pour une plage de A1:N32
pour les Hyper
=NB.SI(A1:N32;">1,7")

pour les hypo
=NB.SI(A1:N32;"<0,7")

ah j'ai oublié les normaux
=NB.SI(A1:N32;"<=1,7")-NB.SI(A1:N32;"<0,7")

j'espère que pour coloriser tes cellules en fonction de la valeur tu utilises la mise en forme conditionnelle, comme dans cet exemple

https://www.cjoint.com/?CIuqfbJf14M

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
5535
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
18 février 2021
571
Bonjour

Un exemple de formules

=NB.SI.ENS($B$5:$O$35;">="&B1;$B$5:$O$35;"<="&B3)

le lien pour le fichier exemple

https://www.cjoint.com/?3Iup4eBAO2w
parfait , ça fonctionne exactement comme je le voulais

merci à tous

sujet clos