Moyenne en tenant compte des cellules vides [Résolu/Fermé]

Signaler
-
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
-
Bonjour,

Je souhaite réaliser une moyenne en comptant les cellules vides. Je m'explique :
J'ai une colonne avec x informations (Bois, pierre, papier, etc). La colonne suivante contient des chiffres... ou pas. Je souhaite faire la moyenne de ces chiffres pour une donnée (Bois par exemple).
La formule que j'utilise est : =Moyenne.Si(colonne A;"Bois";colonne B)
Le problème est que cette formule ignore les cellules vides de telle façon :
Bois / 3 => pris en compte
Bois / = > non pris en compte

Je suis pas sûre d'avoir été clair, alors ici vous pouvez prendre un tit document qui illustre mon problème : http://cjoint.com/?0HmlIQz3s90

Je vous remercie d'avance de votre aide.
Très bonne journée

2 réponses

Messages postés
15534
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
27 janvier 2021
1 440
Bonjour,

pas possible avec formule =moyenne, cellules vides non prise en compte, ce qui est normal puisque non numerique.

deux formules: somme.si et nb.si

https://www.cjoint.com/c/CHmmoQ6zqsP

A+
Messages postés
5533
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
8 janvier 2021
553
Bonjour

Avec une formule comme ça

=SOMME.SI($A$10:$A$100;D3;$B$10:$B$100)/NB.SI($A$10:$A$100;D3)

colonne A libellé
colonne B valeurs
colonne D3 critères bois, D4 pierre, D5 papier