Faire une somme conditionnel de texte [Résolu/Fermé]

Signaler
Messages postés
37
Date d'inscription
mardi 9 juillet 2013
Statut
Membre
Dernière intervention
14 août 2013
-
Messages postés
37
Date d'inscription
mardi 9 juillet 2013
Statut
Membre
Dernière intervention
14 août 2013
-
Slt à tous

Je souhaite faire une somme de différentes colonnes qui contiennent du texte

Ex:

oui ok
oui HP
non ok
non HP
oui ok

Je veux faire la somme de chacune des colonnes en fonction de ce que je veux (somme des "oui" ou somme des "non"...)

Merci à tous

7 réponses

Messages postés
9710
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 avril 2021
2 085
Bonjour

pour le nombre de "oui" dans plage_à_traiter
=NB.SI(plage_à_traiter;"oui")

Bonne journée
Messages postés
37
Date d'inscription
mardi 9 juillet 2013
Statut
Membre
Dernière intervention
14 août 2013

Slt

Petite difficulté supplémentaire,

Je suis dans un tableau avec des filtres et quand j'utilise cette formule, Excel prend aussi en compte les valeurs qui sont écartés par le filtre

En effet j'ai fait par un exemple un filtre pour séparer les bleus et les rouges
mais excel compte les "ok" des bleus et rouges au lieu de ne prendre que les "bleus"

Ps: si ça peu aider pour la formule dans mon tableau on vois en colonne qu'il s'agit des bleus après le filtre

Ex:

Bleus---ok---oui
Bleus---ok---oui
Bleus---HP---non
Bleus---ok---oui

T'a une solution ?
Messages postés
9710
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 avril 2021
2 085
peut être quelque chose du genre

=SOMMEPROD((A2:A20="bleu")*(B2:B20="oui")*1)
Messages postés
37
Date d'inscription
mardi 9 juillet 2013
Statut
Membre
Dernière intervention
14 août 2013

slt

ça marche et si je veux rajouter un autre critère du genre:

la somme des "oui" et des "peut-etre" des "bleus" ?
Messages postés
9710
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 avril 2021
2 085
oui
Messages postés
37
Date d'inscription
mardi 9 juillet 2013
Statut
Membre
Dernière intervention
14 août 2013

?????

Et si je veux faire la somme des "oui" et des "peut-etre" des "bleus" ?

Ex:

Bleus---oui
Bleus---oui
Bleus---peut-etre
Bleus---non
Bleus---non

merci
Messages postés
9710
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
19 avril 2021
2 085
Il te suffit d'additionner les bleu-oui et les bleu-peut être

=SOMMEPROD((A2:A20="bleu")*(B2:B20="oui")*1)+SOMMEPROD((A2:A20="bleu")*(B2:B20="peut être")*1)
Messages postés
37
Date d'inscription
mardi 9 juillet 2013
Statut
Membre
Dernière intervention
14 août 2013

merci