Formule Grande valeur pour des noms

Résolu/Fermé
MarineB63 Messages postés 33 Date d'inscription mercredi 5 septembre 2012 Statut Membre Dernière intervention 10 février 2016 - 22 juil. 2013 à 08:13
pijaku Messages postés 12261 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 - 22 juil. 2013 à 08:39
Bonjour,

Je suis en train de créer des indicateurs et il y en a un qui doit me classer, depuis un tableau de données, le client ayant la plus grande marge brute...
J'ai la formule pour les données (j'utilise grande valeur) par contre je n'arrive pas à aller cherche le nom qui va avec....
Voici un tableau "test" pour vous montrer :
https://www.cjoint.com/c/CGwilq98X6i

J'espère que j'ai été claire dans mes explications,
je vous remercie par avance pour votre répons !
Bonne journée,

4 réponses

Mike-31 Messages postés 18178 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 janvier 2023 5 033
Modifié par Mike-31 le 22/07/2013 à 08:31
Bonjour,

Regarde comme cela

=INDEX(DONNEES!A5:B8;EQUIV(INDICATEUR!C4;DONNEES!B5:B8;0);1)

mais la formule serais plus simple et facile à gérer avec des plages nommées
exemple feuille DONNEES plage A5:B8 nommée list
la plage B5:B8 nommée col_B

la formule deviendrait
=INDEX(list;EQUIV(INDICATEUR!C4;col_B;0);1)

et tu incrémentes vers le bas
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
pijaku Messages postés 12261 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 713
22 juil. 2013 à 08:25
Bonjour,

Dans ton exemple, dans la feuille INDICATEUR, en B4, saisir la formule :
=INDEX(DONNEES!$A$5:$B$8;EQUIV(INDICATEUR!$C4;DONNEES!$B$5:$B$8;0);1)
Formule à étirer vers le bas.
0
MarineB63 Messages postés 33 Date d'inscription mercredi 5 septembre 2012 Statut Membre Dernière intervention 10 février 2016
22 juil. 2013 à 08:35
Vous êtes vraiment des Best et toujours aussi Matinaux...

Merci beaucoup !!!
Ces indicateurs vont m'occuper une bonne partie de la journée, donc je risque de revenir en cas de blocage..
Alors peut être à plus tard !

Marine
0
pijaku Messages postés 12261 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 713
22 juil. 2013 à 08:39
De rien.
N'hésite pas.
A+

ps : salut à Mike, qu'elle rapidité ce matin!!
0
Mike-31 Messages postés 18178 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 janvier 2023 5 033
Modifié par Mike-31 le 22/07/2013 à 08:41
Re,

Une autre proposition peut être plus directe, sur ta feuille INDICATEUR en cellule F4 cette formule à partir de tes plages nommées

=INDEX(list;EQUIV(GRANDE.VALEUR(col_B;LIGNE()-3);col_B;0);1)

et en C4 une simple rechercheV
=RECHERCHEV(A4;list;2;0)

et tu incrémentes les deux vers le bas

PS: Bonjour Pijaku c'est bon à la fraîche on à les idées plus claires
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0