Incrémenter une piéce de méme numéro

Fermé
amine - 18 juil. 2013 à 16:34
PHILOU10120 Messages postés 6195 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 2 février 2023 - 18 juil. 2013 à 16:46
Bonjour,

J'ai un fichier qui contient des numéros de pièces comptables dans une colonne et je veux incrémenter chaque piéce de 1 à n dans une autre colonne, mais une fois on passe d'une piéce à une autre le compteur doit revenir à 1 et commence à nouveau

Je compte sur votre aide

Merci beaucoup


3 réponses

Morgothal Messages postés 1235 Date d'inscription jeudi 22 avril 2010 Statut Membre Dernière intervention 19 mai 2015 179
18 juil. 2013 à 16:40
Bonjour,
Je t'ai fait un classeur exemple pour te montrer :
le classeur exemple
Le seul impératif est d'écrire "1" à la première ligne !

Je reste à dispo si questions il y a !
A+
0
via55 Messages postés 14041 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 7 février 2023 2 551
18 juil. 2013 à 16:40
Bonjour

En supposant les actes en colonne A et commençant en A2

En colonne B pour numeroter en B2 la formule à étirer ensuite
=NB.SI(INDIRECT("A2:A"&LIGNE());A2)

Cdlmnt
0
PHILOU10120 Messages postés 6195 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 2 février 2023 753
Modifié par PHILOU10120 le 18/07/2013 à 16:57
Bonjour

Les numéros des pièces comptables en colonne A4 à Axx
en B4 mettre cette formule si les pièces jointes sont triées par numéro

=SI(A3=A4;B3+1;1)
et la tirer sur la hauteur voulu

et celle-ci si elles ne sont pas triées

=NB.SI($A$3:$A3;A3)

C'est en forgeant que l'on devient forgeron. - C'est au pied du mur que l'on voit le maçon - on apprend toujours de ses erreurs
0