Critère de cellules vides pour une Base de données Excel [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
lundi 15 juillet 2013
Statut
Membre
Dernière intervention
19 juillet 2013
-
Messages postés
4
Date d'inscription
lundi 15 juillet 2013
Statut
Membre
Dernière intervention
19 juillet 2013
-
Bonjour à tous,

Je cherche un moyen d'exprimer un critère pour une base de donnée Excel permettant de compter le nombre de cellules vides.

Le problème, c'est que je ne peux pas utiliser NB.VIDES puisque j'ai plusieurs critères.

Par exemple: Compter le nombre de personnes dont le nom de famille commence par "P" ET dont le numéro de téléphone a été laissé vide.

Merci d'avance,

PyZilla

6 réponses

Messages postés
17295
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 octobre 2020
4 313
Bonjour,

A première vue j'utiliserais SOMMEPROD ou SOMME.SI.ENS suivant la version Excel
mais il faudrait en dire plus sur la structure de la base de données, concernant la colonne de chaque critère par exemple pour avoir des réponses adaptées

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Salut !
Une piste de recherche, en utilisant la fonction SOMMEPROD :
Si par exemple les noms sont de A2 à A10 et les téléphones de B2 à B10 :

=SOMMEPROD((B2:B10="")*(GAUCHE(A2:A10)="p")*1)

la première partie (B2:B10="") teste le nombre de cellules vides
la seconde partie (GAUCHE(A2:A10,1)="p") teste le nombre de cellule dont la premiere lettre à gauche est un p

le *1 permet d'avoir un résultat
Messages postés
4
Date d'inscription
lundi 15 juillet 2013
Statut
Membre
Dernière intervention
19 juillet 2013

Bonjour,

pour répondre à nenuf,
SommeProd n'a pas fonctionné. La réponse reste obstinément 0.

Pour clarifier mon cas, je tiens une liste de dossiers de clients avec des numéro d'identifications et une description de deux activités possibles.

#Dossier Activité #1 Activité #2

J'ai besoin de compter le nombre de clients participant à une activité donnée, exemple "golf", MAIS pas à deux.

#Dossier Activité #1 Activité #2
00001 golf tennis
00002 golf

J'espère avoir été plus précis,

Merci d'avance
PyZilla
Aurais-tu un exemple de ton fichier Excel ? Tu peux utiliser cijoint.com pour le mettre.
Avec je pourrais te montrer ce à quoi je pensais : )
Messages postés
17295
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 octobre 2020
4 313
Bonjour,

Si j'ai bien tout compris pour compter le nombre de golf dans la plage A2:C50

=NB.SI(A2:C50;"golf")
Messages postés
4
Date d'inscription
lundi 15 juillet 2013
Statut
Membre
Dernière intervention
19 juillet 2013

Mike-31,

désolé mais je ne peux pas faire ça. J'ai plusieurs critères à respecter. NB.SI me donnerait 2, alors qu'avec l'exemple en haut, la réponse est 1.

PyZilla
Messages postés
4
Date d'inscription
lundi 15 juillet 2013
Statut
Membre
Dernière intervention
19 juillet 2013

Bonjour à tous,

j'ai résolu mon problème, si on peut dire. Je n'ai toujours pas trouvé le moyen d'exprimer un critère vide dans une base de donnée.

J'ai cependant trouvé un moyen de contourner le problème. Je prends le nombre d'entrées totales moins le nombre d'entrées ayant du texte dans le critère souhaité vide. Pour exprimer une case ayant du texte, j'utilise le critère " ="" ". Avec les formules BD, cela correspond à une cellule ayant quelque chose à l'intérieur.

Merci pour tout l'aide apportée.

Pyzilla