Erreur d'analyse XML : mal formé [Fermé]

Signaler
Messages postés
4
Date d'inscription
vendredi 26 avril 2013
Statut
Membre
Dernière intervention
11 juillet 2013
-
Messages postés
4
Date d'inscription
vendredi 26 avril 2013
Statut
Membre
Dernière intervention
11 juillet 2013
-
Bonjour



Je ne sais pas s'il y a un lien de cause a effet.

Mais il y a quelques jours, j'etais en fin de premiere page et depuis que j'ai cette erreur mon site a reculé sur google de 6 pages.



Erreur d'analyse XML : mal formé
Emplacement : https://www.monsite.net/?q=sitemap.xml
Numéro de ligne 4, Colonne 58 :<sitemap><loc>http://www.monsite.n...emap.xml&page=1</loc><lastmod>2013-07-10</lastmod></sitemap>



A quoi est ce du selon vous ?



Stephane

3 réponses

Bonjour

On ne sait pas quel est ton caractère 58 parce que tu as transformé l'url.
M'étonnerait pas que ce soit le & ou le suivant.
Il ne devrait pas y avoir plutôt &amp; au lieu d'un simple & ?
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64073 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
vendredi 26 avril 2013
Statut
Membre
Dernière intervention
11 juillet 2013
1
Je vais donner le message original dans son intégralité

Erreur d'analyse XML : mal formé
Emplacement : http://www.indicerh.net/?q=sitemap.xml
Numéro de ligne 4, Colonne 58 :<sitemap><loc>http://www.indicerh.net/?q=sitemap.xml&page=1</loc><lastmod>2013-07-10T19:04Z</lastmod></sitemap>
---------------------------------------------------------^
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64073 internautes nous ont dit merci ce mois-ci


Ça correspond bien à un problème de caractère spécial.
As-tu essayé de remplacer le & par un &amp; comme je te l'avais suggéré ? Le caractère & seul est illégal en XML, si j'en crois ce document : https://www.w3schools.com/xml/xml_syntax.asp
Messages postés
4
Date d'inscription
vendredi 26 avril 2013
Statut
Membre
Dernière intervention
11 juillet 2013
1
Je ne sais pas trop ce que je dois faire, en fait sur drupal xml sitemap me fournit cette page la et ce qui est bizarre est qu'elle fonctionne sur un autre site que j'ai : indicerh.com

http://indicerh.com/?q=sitemap.xml