Comment trouver une donnée identique à 2 fichiers [Résolu/Fermé]

Signaler
Messages postés
15
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
8 juillet 2013
-
Messages postés
12867
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 novembre 2020
-
Bonjour,

J'ai 2 fichiers. Le 1er est le fichier complet de tous mes dossiers clients et le 2ème est un fichier dans lequel se trouve tous les dossiers ayant tournés depuis le 1er janvier 2013.
J'aimerais faire une formule qui m'indiquerait dans le 1er fichier si le dossier a tourné ou non depuis le 1er janvier 2013.
Comment puis-je faire ?
Merci d'avance pour vos réponses

Senga15

7 réponses

Messages postés
12867
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 novembre 2020
2 075
Bonsoir

Un exemple :
https://www.cjoint.com/?3Fxu5e88Rqa

Cdlmnt
Messages postés
15
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
8 juillet 2013

Bonsoir,
merci pour la réponse mais dans le fichier client il y a le code AAa et pas dans le ?2013 et cela indique malgré tout le résultat "oui".
J'ai essayé dans mes fichiers et cela fait pareil
Ou est l'erreur ?
Merci de bien vouloir me dire ce que nous ne faisons pas correctement
Cordialement
Messages postés
12867
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 novembre 2020
2 075
Bonsoir

Je ne comprends pas
Si AAa n'existe pas dans 2013 RECHERCHEV retrourne une erreur donc "" et ne peut pas donner "oui"

Cela n'indique pas oui chez moi pour AAa
j'ai oui pour BBb, CCc, FFf, GGg, GGh et LLm

Joins un exemple anonymé et allégé de ton fichier , on verra ce qui cloche

Cdlmnt
Messages postés
15
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
8 juillet 2013

Bonjour,

Voici votre exemple

https://www.cjoint.com/?CFyhceFZkyK

Cas avec code client existant
Code Nom Prenom 2013
C1 AA a oui N'existe pas dans fichier 2013 et résultat Oui
C2 BB b oui
C3 CC c oui Dans les 2 cas on recherche le code client dans la feuille 2013 avec une RECHERCHEV
C4 DD d oui On affiche rien(« « ) si pas trouvé et oui sinon
C5 EE e oui
C6 FF f oui
C7 GG g oui
C8 GG h oui
C9 JJ j oui
C10 LL m oui

Cas sans code client existant
création d'un code par concaténation du nom et du prénom
Code Nom Prenom 2013
AAa AA a oui N'existe pas dans fichier 2013 et pourtant résultat Oui
BBb BB b oui
CCc CC c oui
DDd DD d oui
EEe EE e oui
FFf FF f oui
GGg GG g oui
GGh GG h oui
JJj JJ j oui
LLm LL m oui

Cordialement
Messages postés
2172
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 novembre 2020
299
Bonjour

dans la formule de VIA55 il faut déplacer une parenthèse fermante et la mettre derrière le 1
=SI(ESTERREUR(RECHERCHEV(A3;'2013'!A$3:A$10;1;0)=1);"";"oui")

cdlt
Messages postés
2172
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 novembre 2020
299
ou =SI(ESTERREUR(RECHERCHEV(A18;'2013'!A$16:A$22;1;0));"";"oui")
Messages postés
15
Date d'inscription
dimanche 23 juin 2013
Statut
Membre
Dernière intervention
8 juillet 2013

Merci beaucoup cette formule fonctionne

=SI(ESTERREUR(RECHERCHEV(A3;'2013'!A$3:A$10;1;0)=1);"";"oui")

Bonne journée

Cordialement
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
Bonjour

dans la formule de Via, le =1 est inutile (garder la parenthèse)
et peut être pour faire un peu plus simple:
en D3 feuille Clients
=SI(NB.SI(2013!A:A;A3);"oui";"")

crdlmnt
Messages postés
12867
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 novembre 2020
2 075
Bonjour à tous

Il ya apparement une différence entre Libre Office sur lequel je suis et Open, je maintiens que chez moi la formule marche comme cela mais pas lorsque j'applique celle de Frenchie qui me renvoie Err 508 de meme que la formule de Vaucluse qui me renvoie Err 502
Je le signale pour tous ceux qui travaillent avec Libre Office

Cdlmnt