Calcul Matricielle : Date en ligne et Critères en colonne

[Résolu/Fermé]
Signaler
-
 Noob_In_Matrice -
Bonjour,


je ne suis pas un expert des matrices, voici mon problème :

J' ai un tableau rempli comme suit : Le 1er janvier, le problème n°1 a été rencontré, le 20 janvier les problèmes n°2 et 3 ont été rencontré.
Le 12 mars le problème 1 a été à nouveau rencontrer.

___B___|____C____|____D____|____E___|
| Pbm 1 | Pbm 2 | Pbm 3 |
01/1/13 | X X
20/1/13 | X X
12/3/13 | X
14/4/13 | X X


Je voudrais pouvoir créer un tableau me donnant pour chaque mois, le nombre de fois que chaque problème a été rencontré, soit

Janvier | Fevrier | Mars | Avril
Pbm 1 1
Pbm 2 2
Pbm 3 1

Je pense que je ne suis pas loin car :

1°) J' ai le nombre de jour d' alerte par mois : =SOMMEPROD(B2:B7>=DATEVAL("1/1/13");B2:B7<=DATEVAL("31/1/13"))

2°) le nombre de X par ligne : 1
=NBVAL(C2:F2)


Il faut juste la bonne formule matricielle au bonne endroit

5 réponses

Messages postés
24204
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
6 937
Bonjour,

Déposer le fichier xls (réduit au nécessaire et anonymisé, avec les explications et éventuellement le résultat attendu) sur cjoint.com et coller ici le lien fourni.

eric

Bonjour,

voici mon fichier simplifié : http://cjoint.com/?0FulFJAykD2


En haut il y a mon tableau de données rempli manuellement sur lequel je veux travailler et en bas le tableau de suiv que je cherche à remplir en fonction du contenu de mon tableau de données
Messages postés
17602
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 octobre 2021
4 787
Bonjour,

en C36

=SOMMEPROD((MOIS(B3:B11)=1)*(D3:D11="X"))

le 1 correspond au mois de janvier
MOIS(B3:B11)=1
Messages postés
10161
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 octobre 2021
2 232
Bonjour

Un début de réponse
https://www.cjoint.com/?3Ful6d2WmZL

Bonne suite

Bonjour,

la formule de Mike-31 fonctionne parfaitement bien. Mon problème est donc résolu

Merci à vous.